Bug #90472

Deprecated default value "5,6" for excludeDoktypes in HMENU

Added by Nikita Hovratov 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Documentation
Target version:
-
Start date:
2020-02-21
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Enter the list of page document types (doktype) to exclude from menus. By default pages that are “not in menu” (5) are excluded and those marked for backend user access only (6).

Since TYPO3 4.2 the page doctype 5 got removed. The "new" default value is "6".

Associated revisions

Revision b8c2dd25 (diff)
Added by Georg Ringer 3 months ago

[BUGFIX] Remove outdated information about doktype 5 from tsref.xml

Once upon a time there was a doktype 5 for "not in menu" pages which has
been moved to a checkbox since a long time.

The outdated information can be removed.

Resolves: #90472
Releases: master
Change-Id: I8755a69cad778afe25527e90521963b5cb87de68
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63441
Tested-by: Christian Eßl <>
Tested-by: Nikita Hovratov <>
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Christian Eßl <>
Reviewed-by: Nikita Hovratov <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi 3 months ago

Same wrong values are cited in the file /typo3/sysext/t3editor/Resources/Private/tsref.xml

#2 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63441

#3 Updated by Georg Ringer 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF