Bug #90662

Avoid "view webpage" for Records of type "Page Content" on storage

Added by Daniel Koether 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2020-03-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hello everyone,

many extension use relations to records of type "Page Content" i.e. EXT:news (field: content_elements). This Content Elements often are placed on storage folders (see attached screenshot) because they are not used on pages and only in specific areas of an extension detail view.

Anyway I think the option "view webpage" (see also attached screenshot) does not make sense on storage pages and irritate editors because in the most cases they get conducted to the 404 error page / broken or empty page.

Possible solution:
Deactivate the view webpage action for records of type "Page content" on storages by default.

Thanks in advance and keep up the good work!
Daniel


Files


Related issues

Related to TYPO3 Core - Bug #55300: Inconsistent handling of Sys-foldersClosed2014-01-24

Actions
#1

Updated by Christian Eßl 9 months ago

  • Related to Bug #55300: Inconsistent handling of Sys-folders added
#2

Updated by Christian Eßl 9 months ago

There is a patch for that, that is currently under review in: #55300

#3

Updated by Daniel Koether 9 months ago

Christian Eßl wrote:

There is a patch for that, that is currently under review in: #55300

Thank you! I didn't noticed that this bug is currently in process.

#4

Updated by Riccardo De Contardi 9 months ago

Daniel Hinderink Koether do you mind if I close your issue? The discussion could continue on #55300, ok?

#5

Updated by Daniel Koether 9 months ago

Of course, please close the issue. Would closed it by myself if I had found the option ;)

Thank you!

#6

Updated by Bjoern Jacob 9 months ago

  • Status changed from New to Closed

Thank you for your feedback. Closing this issue as requested :)

Also available in: Atom PDF