Bug #90916

Page type external URL, removes fragments from relativ URLs

Added by Christian Wolff over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-04-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After updating to TYPO3 9.5.15

pages with external URL and a relativ URL with a Fragment do not resolve correctly

we have urls like this `/home/#fragment` used in Menus. to comunicate a the routing information to an Javascript app (angular).

before TYPO3 9.5.15 everything worked as expected.

as a fix we have changed the relativ URLs to Absolute URLs: `https://domain.tld/home/#fragment`

i suspect the following commit introduced the problem:

https://github.com/TYPO3/TYPO3.CMS/commit/0597c09389eacb9ce77ab32ae618171fe5cd350b


Related issues

Related to TYPO3 Core - Bug #75213: Missing Anchors for PDFsClosed2016-03-21

Actions
Related to TYPO3 Core - Bug #91357: Typolink strips #Closed2020-05-11

Actions
#1

Updated by Christian Eßl over 1 year ago

  • Related to Bug #75213: Missing Anchors for PDFs added
#2

Updated by Riccardo De Contardi over 1 year ago

  • Category set to Link Handling, Site Handling & Routing
#3

Updated by Christian Eßl over 1 year ago

That's interesting. Page type "External Url" isn''t supposed to be used for relative urls, but apparently it just "works".
What happens is : because the url does not contain double slashes, that make it recognizable as "external url", it is then treated as "file or folder" in the code. The code then fails to find a file or folder for the url and then falls back to type "unknown" and just directly outputs the relative url without modifying it.

The url fragment changes were only made in the code that treats "file or folder" urls. And this now breaks the behaviour for this unusual use of the external doktype as well because of the reasons stated above.

#4

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#5

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#6

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#7

Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#8

Updated by Benni Mack over 1 year ago

#9

Updated by Gerrit Code Review over 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#10

Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#11

Updated by Gerrit Code Review over 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#12

Updated by Gerrit Code Review over 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#13

Updated by Gerrit Code Review over 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64411

#14

Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64368

#15

Updated by Benni Mack over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF