Project

General

Profile

Actions

Feature #90931

closed

Add option to disable version highlighting in the page tree

Added by Uwe Trotzek about 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2020-04-02
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

In larger instances the highlighting of versions in the page tree is a performance killer. The more pages and tables the instance gets, the slower the loading of the page tree becomes.

If it cannot simply achieved to gain performance boost here, there could be at least an option added to disable the highlighting for some users.

I will add a patch which we are using for quite a while to disable the highlighting. The configuration part needs to be added if this is a desired workaround.

This one here is the slow part: https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/backend/Classes/Controller/Page/TreeController.php#L504


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #91728: Very slow tree loading if you have multiple workspaces TYPO3 v10Closed2020-06-30

Actions
Related to TYPO3 Core - Bug #88943: Pagetree taking extremely long to load for editorsClosed2019-08-09

Actions
Actions #1

Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64052

Actions #2

Updated by Danilo Caccialanza almost 4 years ago

  • Related to Bug #91728: Very slow tree loading if you have multiple workspaces TYPO3 v10 added
Actions #3

Updated by Danilo Caccialanza almost 4 years ago

I confirm the problem as it has been described and that the patch solves the performance problem.

In my opinion you can release this patch, but it should not be the final solution of the problem because the color of the versioned page is important and I don't want to be forced to disable it to improve performance!

Actions #4

Updated by Danilo Caccialanza almost 4 years ago

Performance problems are solved with 10.4.6 and 9.5.20.

"2020-07-23 a253b871c5 [BUGFIX] Limit amount of data fetched by the page tree (thanks to Tymoteusz Motylewski)"

In my opinion this functionality is no longer necessary.

Actions #5

Updated by Christian Kuhn almost 4 years ago

Let's keep this issue open for just another couple of days, giving the author an option to answer.
Other than that I'd agree we could basically close the issue as a duplicate of #91728, the patch for issue #88943 should have mitigated the issue a lot.

Actions #6

Updated by Christian Kuhn almost 4 years ago

  • Related to Epic #88474: Page tree performance in 9.5 added
Actions #7

Updated by Christian Kuhn almost 4 years ago

  • Related to deleted (Epic #88474: Page tree performance in 9.5)
Actions #8

Updated by Christian Kuhn almost 4 years ago

  • Related to Bug #88943: Pagetree taking extremely long to load for editors added
Actions #9

Updated by Christian Kuhn almost 4 years ago

  • Status changed from Under Review to Closed

Closing issue now. Please ping us if you object.

Actions #10

Updated by Uwe Trotzek almost 4 years ago

I'm not 100% sure if this can be closed or not. The highlighting of changes in the page tree has definitely performance impact. In my local dev system with only a few changes made by myself it is about 3 seconds. (6 sec with the patch, 9 sec. without the patch)

I wrote this patch because we had huge performance issues in our production environment. We have to test if the issues will come back as soon as our editors make more changes in production. I can imagine that they will come back because we had these performance issues BEFORE the page tree refactoring in TYPO3 9. The problems were also present under 8.7.

But we'll see. ;-) I will give some feedback. But it will take some time until we have the project in production.

Actions #11

Updated by Danilo Caccialanza almost 4 years ago

Yes, it may be that with the improvement of the tree performances the "highlighting of versions" problem has also improved but the performances for "highlighting of versions" are not yet completely satisfactory.

Actions #12

Updated by Christian Kuhn almost 4 years ago

  • Status changed from Closed to New
Actions #13

Updated by Riccardo De Contardi about 1 month ago

On version 13 the pagetree has been reworked AFAIK to be native HTML5.
Plus, the pages modified in a workspace are now marked with a "yellow dot" on the right side.

Is this issue still relevant?

Thanks.

Actions #14

Updated by Danilo Caccialanza about 1 month ago

Riccardo De Contardi wrote in #note-13:

On version 13 the pagetree has been reworked AFAIK to be native HTML5.
Plus, the pages modified in a workspace are now marked with a "yellow dot" on the right side.

Is this issue still relevant?

Thanks.

No, this issue is no longer relevant, thank you!

Actions #15

Updated by Riccardo De Contardi about 1 month ago

  • Status changed from New to Closed

I close this very old issue for now

If there are specific issues / features about the performance of the new PageTree , please open new issues

Thank you.

Actions

Also available in: Atom PDF