Project

General

Profile

Actions

Bug #90932

closed

PseudoSiteTcaDisplayCondition always checks l10n_parent

Added by Tobias Kapplmüller over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-04-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the DisplayCondition, that is used to disable the slug field when editing a PseudoSite (https://github.com/TYPO3/TYPO3.CMS/blob/9.5/typo3/sysext/core/Classes/Compatibility/PseudoSiteTcaDisplayCondition.php) in line 65, the l10n_parent of a page is used as uid for the SiteMatcher, even if l10n_parent and sys_language_uid are both 0.

Therefore, if both of those fields are zero, the condition thinks its a new page and checks the parent page. Because of that, the slug field can wrongfully be hidden for some pages


Related issues 3 (1 open2 closed)

Related to TYPO3 Core - Bug #90736: Wrong slug fields for siteroots (level > 1) in multidomain environment and no possibility to modify themNew2020-03-11

Actions
Has duplicate TYPO3 Core - Bug #89014: Field slug should be editable on page where SiteConfiguration is locatedClosed2019-08-26

Actions
Is duplicate of TYPO3 Core - Bug #89485: Editing a slug field on a root page (page with SiteConfiguration) is not possible if parent uid of this root page is > 0 and TreeRoot has no site configurationClosed2019-10-23

Actions
Actions

Also available in: Atom PDF