Bug #91418

UnknownClassException with Fluid autocomplete widget

Added by Oliver Hader about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2020-05-16
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

<f:widget.autocomplete objects="{categories}" for="field" searchProperty="title" />

Observations

  • ReflectionService::buildClassSchema called with empty ('') argument - no class name given
  • WidgetRequestBuilder does not assign controllerObjectName
  • $request->getCntrollerObjectName() being empty as a result

TYPO3 Exception.html View (218 KB) Oliver Hader, 2020-05-16 15:45


Related issues

Related to TYPO3 Core - Task #87550: Use controller classes when registering plugins/modules Closed 2019-01-25
Related to TYPO3 Core - Bug #91382: Ajax Widgets with QueryResult Object as Argument throw an Error since 9.5.17 Closed 2020-05-13

Associated revisions

Revision 7c4699b2 (diff)
Added by Alexander Schnitzler about 2 months ago

[BUGFIX] Set controller object name for widget request

While introducing the fully qualified controller class names
in the extbase plugin configuration the originally used setter
\TYPO3\CMS\Extbase\Mvc\Request::setControllerObjectName() has
no longer been used to guess extension name, subpackage key and
controller name from the class name since all that information
is known. Said setter has been kept nevertheless and it was
overlooked that it was still used by fluid widgets. This leads
to property \TYPO3\CMS\Extbase\Mvc\Request::$controllerObjectName
being empty in widget requests which then leads to an exception
when trying to create a ClassSchema for the controller object
name "".

To fix this, the widget request is now created with the controller
object name as constructor argument.

Releases: master
Resolves: #91418
Change-Id: I6abcdb8c68e831459228cc35c3263cec83d16f67
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64505
Tested-by: Susanne Moog <>
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Oliver Hader <>

History

#2 Updated by Oliver Hader about 2 months ago

Most probably related to https://review.typo3.org/c/Packages/TYPO3.CMS/+/59566/11/typo3/sysext/extbase/Classes/Mvc/Request.php#b135

WidgetRequestBuilder was forgotten to be adjusted

#3 Updated by Oliver Hader about 2 months ago

  • Related to Task #87550: Use controller classes when registering plugins/modules added

#4 Updated by Oliver Hader about 2 months ago

  • Related to Bug #91382: Ajax Widgets with QueryResult Object as Argument throw an Error since 9.5.17 added

#5 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64505

#6 Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64505

#7 Updated by Oliver Hader about 2 months ago

  • Target version set to 9.5.18 & 10.4.3

#8 Updated by Gerrit Code Review about 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64505

#9 Updated by Gerrit Code Review about 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64505

#10 Updated by Anonymous about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF