Bug #91708

ReferenceIndex doesn't take care if softref value is changed in columnsOverrides for a particular type

Added by Josef Glatz about 1 year ago. Updated 12 months ago.

Status:
Rejected
Priority:
Could have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2020-06-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem/Description

It's not possible to override the TCA softref config option for a specific type of a table.

Real world example:

  • Add a new page type
  • Override the softref value to typolink for that specific type
  • no softref will be added after saving the record due to the fact that the default TCA value for the sofref value url will be used

ToDo(s) / Questions

  • Of course it would be really cool when the ReferenceIndex supports "each" type of "TCA overriding ways"
  • On the other side it does not hurt if I override the default value in my extension, since it will be O.K. that softref checks for multiple types of soft references
#1

Updated by Josef Glatz about 1 year ago

  • Category changed from DataHandler aka TCEmain to Miscellaneous
#2

Updated by Josef Glatz about 1 year ago

  • Category changed from Miscellaneous to Database API (Doctrine DBAL)
#3

Updated by Oliver Bartsch about 1 year ago

The evaluation taking place in

TYPO3\CMS\Core\Database\ReferenceIndex::getRelations()
doesn't consider the
processedTca
like you would get it from the FormDataProviders but directly accesses
$conf = $GLOBALS['TCA'][$table]['columns'][$field]['config'];
the columns config without further processing of e.g. columnsOverrides or OverrideChildTca.

#4

Updated by Christian Kuhn 12 months ago

  • Status changed from New to Rejected

Hey.

Sorry, I'll have to reject this: columnsOverrides and overrideChildTca only work for 'display' related properties (FormEngine only), they are not at all taken into account in data handling scenarios.

This restriction isn't that great, but won't change anytime soon. Both properties are also documented that they have this restriction.

Also available in: Atom PDF