Project

General

Profile

Actions

Bug #91851

closed

Page module translation wizard shows duplicate records if in workspace

Added by Christian Kuhn over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2020-07-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Yes
Sprint Focus:

Description

The translation wizard modal that copies/connects content elements to a new page translation shows and creates the double amount of content elements if translating content in a workspace.

Reproduce:
- Have a workspace configured on pid 0
- Have a second non default language for a site
- Create a page in live
- Go to workspace
- Create a content element in default language in workspace
- Create a page translation
- Click the 'translate' button in page module -> modal -> copy or translate -> 2 (!) records are shown and two records are created but only ONE record should be shown and created


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #89555: Querying records in workspaces does not return all proper values due to "pid=-1" databaseClosedBenni Mack2019-09-132019-09-13

Actions
Actions #1

Updated by Christian Kuhn over 3 years ago

  • Related to Bug #89122: Inconsistent evaluation of pid=-1 with workspace records added
Actions #2

Updated by Christian Kuhn over 3 years ago

  • Related to deleted (Bug #89122: Inconsistent evaluation of pid=-1 with workspace records)
Actions #3

Updated by Christian Kuhn over 3 years ago

  • Related to Bug #89555: Querying records in workspaces does not return all proper values due to "pid=-1" database added
Actions #4

Updated by Christian Kuhn over 3 years ago

  • Subject changed from Page module localisation wizard shows duplicate records if in workspace to Page module translation wizard shows duplicate records if in workspace
Actions #5

Updated by Christian Kuhn over 3 years ago

  • Description updated (diff)
Actions #7

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65076

Actions #8

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65029

Actions #9

Updated by Christian Kuhn over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF