Project

General

Profile

Actions

Bug #89122

closed

Inconsistent evaluation of pid=-1 with workspace records

Added by Benni Mack almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Start date:
2019-09-11
Due date:
2019-09-11
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #13056: admin users see all changes in LIVE workspaceClosedOliver Hader2011-02-15

Actions
Related to TYPO3 Core - Bug #91983: Drop 'Live workspace' tab from workspace moduleClosed2020-08-11

Actions
Related to TYPO3 Core - Bug #93993: BackendUtility::getTSconfig_pidValue still uses pid check for determination of workspace stateClosedOliver Bartsch2021-04-27

Actions
Follows TYPO3 Core - Bug #89138: Correctly retrieve workspace versionsClosed2019-09-10

Actions
Precedes TYPO3 Core - Bug #89555: Querying records in workspaces does not return all proper values due to "pid=-1" databaseClosedBenni Mack2019-09-132019-09-13

Actions
Actions #1

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61641

Actions #2

Updated by Oliver Hader almost 5 years ago

  • Due date set to 2019-09-11
  • Start date changed from 2019-09-10 to 2019-09-11
  • Follows Bug #89138: Correctly retrieve workspace versions added
Actions #3

Updated by Gerrit Code Review almost 5 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61641

Actions #4

Updated by Gerrit Code Review almost 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61641

Actions #5

Updated by Benni Mack almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack over 4 years ago

  • Status changed from Resolved to Closed
Actions #7

Updated by Christian Kuhn about 4 years ago

  • Related to Bug #91851: Page module translation wizard shows duplicate records if in workspace added
Actions #8

Updated by Christian Kuhn about 4 years ago

  • Related to deleted (Bug #91851: Page module translation wizard shows duplicate records if in workspace)
Actions #9

Updated by Christian Kuhn about 4 years ago

  • Precedes Bug #89555: Querying records in workspaces does not return all proper values due to "pid=-1" database added
Actions #10

Updated by Christian Kuhn almost 4 years ago

  • Precedes Bug #91881: Massive load when deleting sys_workspace record on pid 0 added
Actions #11

Updated by Christian Kuhn almost 4 years ago

  • Precedes deleted (Bug #91881: Massive load when deleting sys_workspace record on pid 0)
Actions #12

Updated by Christian Kuhn almost 4 years ago

  • Related to Bug #13056: admin users see all changes in LIVE workspace added
Actions #13

Updated by Christian Kuhn almost 4 years ago

  • Related to Bug #91983: Drop 'Live workspace' tab from workspace module added
Actions #14

Updated by Christian Kuhn about 3 years ago

  • Related to Bug #93993: BackendUtility::getTSconfig_pidValue still uses pid check for determination of workspace state added
Actions

Also available in: Atom PDF