Bug #91899

Workspace: No content elements in preview if live page has endtime in the past

Added by Christian Kuhn 3 months ago. Updated 3 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2020-07-30
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

This popped up in #82462 with comment #18 first, but is different than the already fixed initial issue from #82462. To de-mess forge a bit, this is now extracted as an own issue.

1) Have a plain TYPO3 installation
2) Create a draft Workspace
3) Create a page in live mode
4) Add a content element to that page
5) Set the expiration date of the page to something in the past and save
6) Switch to draft Workspace
7) Remove the expiration date from the page
8) Save and preview the page

Expected result:
You should be able to see page and its content elements.

Current result:
You'll be able to view the page but no content elements appear.

Note:
When playing around with that, consider the different things that happen if fiddling with the 'simulate time' box in the admin panel in live and workspace preview, and the live version of the page in workspace preview if using the slider.


Related issues

Related to TYPO3 Core - Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable Closed 2017-09-12

History

#1 Updated by Christian Kuhn 3 months ago

  • Description updated (diff)

#2 Updated by Christian Kuhn 3 months ago

  • Related to Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable added

Also available in: Atom PDF