Project

General

Profile

Actions

Bug #91985

closed

options.file_list.uploader.defaultAction is not working

Added by Eric Chavaillaz over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2020-08-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

With the drag uploader, it is possible to set a default strategy (https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/10.1/Feature-86670-MakeDefaultActionInDragUploaderAdjustable.html) but it is not working.

In fact, if I put `options.file_list.uploader.defaultAction = replace`, the replace option is selected but when I confirm the upload nothing append. In this case the rename strategy works well and the cancel also.

It is the same with rename. Rename does not work, but replace and cancel yes.

Thanks


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Feature #86670: Make default action in DragUploader adjustableClosedFrank N├Ągler2018-10-16

Actions
Actions #1

Updated by Eric Chavaillaz over 3 years ago

  • Related to Feature #86670: Make default action in DragUploader adjustable added
Actions #2

Updated by Kevin Appelt over 3 years ago

  • Priority changed from Should have to Must have

We have the same problem. Currently we have removed the corresponding line in TSconfig to make the system "usable".
It seems to be a JS problem. The configured action is preselected, but this action cannot be executed. If the user adjusts the action, the selected action will be executed correctly. This is also the case if another action is selected and then the user switches back to the "default" action.

Actions #3

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65398

Actions #4

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65398

Actions #5

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65422

Actions #6

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65422

Actions #7

Updated by Kevin Appelt over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF