Bug #92381

Button "Create new" does not re-appear for inline (IRRE) elements after reaching maxitems and removing one element

Added by Christian Buelter 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2020-09-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a "maxitems" TCA configuration is set for inline elements, the "Create new" button disappears after reaching the maxitems limit, but the button does not re-appear if one element is deleted.

The button will re-appear after saving the record.

If there's also a value configured for "minitems" and "minitems" = "maxitems", it's not possible to save the record. Therefore it is not possible to remove the inline element at all, meaning it is not possible to remove one and add another element.

Expected behaviour

After reaching the limit of inline elements configured in "maxitems" and removing one element, the "Create new" button should re-appear.

Tested in TYPO3 10.4.6 and news 8.4.0

Steps to reproduce (using EXT:news as an example)

1. Install EXT:news

2. Set the following PageTS

TCEFORM.tx_news_domain_model_news.related_links.config.minitems = 1
TCEFORM.tx_news_domain_model_news.related_links.config.maxitems = 1

3. Add a news element. Add a "related link" element inside the news element using the "Create new" button. The "Create new" button disappears. Remove the "related link" element. The "Create new" button still is gone.


Related issues

Related to TYPO3 Core - Bug #78479: FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous oneClosed2016-10-28

Actions
Related to TYPO3 Core - Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrongClosed2020-07-16

Actions
#1

Updated by Christian Buelter 10 months ago

  • Related to Bug #78479: FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one added
#2

Updated by Christian Buelter 10 months ago

  • Description updated (diff)
#3

Updated by Christian Buelter 10 months ago

  • Description updated (diff)
#4

Updated by Oliver Bartsch 10 months ago

  • Status changed from New to Needs Feedback

Hi, I'm not able to reproduce the behaviour. This should already be fixed in latest v10 (10.5.9) with this patch: https://forge.typo3.org/issues/91808.

Could you please check if you can still reproduce it with this patch applied.

#5

Updated by Oliver Bartsch 10 months ago

  • Related to Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrong added
#6

Updated by Christian Buelter 10 months ago

Patch https://forge.typo3.org/issues/91808 fixes the problem in my test case, thank you.

#7

Updated by Oliver Bartsch 10 months ago

  • Status changed from Needs Feedback to Closed

Thanks for the fast feedback. I will therefore close this issue.

Also available in: Atom PDF