Bug #92654

The label of pages.no_search field is still "No search" which leads to wrong display in recordlist

Added by Oliver Bartsch about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2020-10-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
tas2020, accessibility
Complexity:
Is Regression:
Sprint Focus:

Description

Since some TCA columns use the invertStateDisplay option for display in FormEngine nowadays, the corresponding labels had to be adjusted.

This was however not done for the pages.no_search field. Only the formlabel, used in FormEngine was changed to "Include in Search". The TCA records label which is used in e.g. recordlist still displays "No search" which is now wrong (since the field is inverted).


Files

no-search-label.png (6.18 KB) no-search-label.png Oliver Bartsch, 2020-10-21 18:37

Related issues

Related to TYPO3 Core - Bug #92603: The context sensitive help description text of pages.no_search is wrong since the appearance of the field in the backend has been changed.Resolved2020-10-19

Actions
Has duplicate TYPO3 Core - Feature #91802: Misleading TCA-Label in BE Page -> Listmodule for field 'no_search' in table pagesClosed2020-07-15

Actions
#1

Updated by Oliver Bartsch about 1 month ago

  • Related to Bug #92603: The context sensitive help description text of pages.no_search is wrong since the appearance of the field in the backend has been changed. added
#2

Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66240

#3

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66200

#4

Updated by Oliver Bartsch about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Oliver Bartsch 22 days ago

  • Related to Feature #91802: Misleading TCA-Label in BE Page -> Listmodule for field 'no_search' in table pages added
#6

Updated by Oliver Bartsch 22 days ago

  • Related to deleted (Feature #91802: Misleading TCA-Label in BE Page -> Listmodule for field 'no_search' in table pages)
#7

Updated by Oliver Bartsch 22 days ago

  • Has duplicate Feature #91802: Misleading TCA-Label in BE Page -> Listmodule for field 'no_search' in table pages added

Also available in: Atom PDF