Bug #93129

Crop an image from a storage not inside TYPO3s folder fails

Added by Christian Stern 10 months ago. Updated 5 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Image Cropping
Target version:
-
Start date:
2020-12-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We use a storage that is outside of the TYPO3 folder.

All uses of the files from this folder work perfectly: frontend, in all image view helpers, filelist and so on.

Now an editor has noticed the following when cropping the picture:

No picture is loaded. See the screenshot:

The image cropping program calls the following URL which causes a 500 error: /index.php?eID=dumpFile&t=f&f=50287&token=8a6fe7ef5f5d8492810a5b623dd9ffe74f9cf70e

The following error appears in the error log: See screenshot:

For deployment reasons we cannot move the folder to the TYPO3 folder.

What I've tried so far:

The path set relatively: the same error
The path set absolutely: the same error

Is this maybe related to: https://forge.typo3.org/issues/90330


Files

crop.JPG (146 KB) crop.JPG Christian Stern, 2020-12-20 20:19
fehler.JPG (379 KB) fehler.JPG Christian Stern, 2020-12-20 20:19
index-php-1608496191277.png (491 KB) index-php-1608496191277.png Christian Stern, 2020-12-20 20:31
#1

Updated by Christian Stern 10 months ago

  • File screencapture-www-theaterkompass-de-ddev-site-index-php-1608496191277.png added
#2

Updated by Christian Stern 10 months ago

  • File deleted (screencapture-www-theaterkompass-de-ddev-site-index-php-1608496191277.png)
#4

Updated by Christian Stern 10 months ago

  • Subject changed from Crop image from a storage not inside TYPO3s install folder to Crop an image from a storage not inside TYPO3s folder fails
#5

Updated by Riccardo De Contardi 9 months ago

  • Category set to Image Cropping
#6

Updated by Katja Lutz 9 months ago

I am encountering this as well :)

#7

Updated by Mathias Brodala 9 months ago

  • Description updated (diff)
#8

Updated by Katja Lutz 8 months ago

Quick update from my side: in our case the error lay in our own, custom built extension which had a fatal flaw in its extTablesInclusion-PostProcessing hook.

#9

Updated by Christian Stern 5 months ago

It looks like with 10.4.15 this false behavior is resolved. I can not reproduce it anymore.

Can anyone else confirm, that images are loaded correctly from any storages?

Also available in: Atom PDF