Project

General

Profile

Actions

Bug #93410

closed

The download of pdf files via privatestorage/eID returns an image

Added by Altan Tosun about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Image Cropping
Target version:
-
Start date:
2021-02-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.4
Tags:
pdf, image, FileDumpController, processing
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Core Bug/Case: TYPO3 Version 10.4.12, PHP 7.4

namespace TYPO3\CMS\Core\Controller\FileDumpController:85;

The issue is that this is an unexpected behavour. The function tries to process everything.

        // Apply cropping, if possible
        if (!$file instanceof ProcessedFile) {
            $cropVariant = $parameters['cv'] ?: 'default';
            $cropString = $file instanceof FileReference ? $file->getProperty('crop') : '';
            $cropArea = CropVariantCollection::create((string)$cropString)->getCropArea($cropVariant);
            $processingInstructions = [
                'crop' => $cropArea->isEmpty() ? null : $cropArea->makeAbsoluteBasedOnFile($file),
            ];

Expectation should be to get the original file and not an unexpected behavour. If I want to process images, I want to use explicit image processes. Same goes for huge images, for example image databases. At least there should be an config or setting to change this behavour.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #90068: Implement better FileDumpControllerClosedStefan Froemken2020-01-08

Actions
Is duplicate of TYPO3 Core - Bug #93024: PDF download from private storage yields thumbnailClosed2020-12-08

Actions
Actions #1

Updated by Altan Tosun about 3 years ago

  • Related to Feature #90068: Implement better FileDumpController added
Actions #2

Updated by Altan Tosun about 3 years ago

  • Is duplicate of Bug #93024: PDF download from private storage yields thumbnail added
Actions #3

Updated by Mathias Brodala almost 3 years ago

  • Status changed from New to Resolved
Actions #4

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF