Bug #93649

Workspace conflit

Added by X B 5 months ago. Updated 4 months ago.

Status:
Needs Feedback
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2021-03-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

Hello, I have a big workspace conflict.
When in a worksapce, we are in the "publish" module, we have an error:

router
Element "sys_file_reference: 18195" does not exist

I went to the sys_file_reference table and deleted a row that pointed to a sys_file_reference that didn't exist.
After emptying the caches, I still have the same error.

We have a TYPO3 7.50

Thanks for your help :) :)

#1

Updated by Dave Zen 5 months ago

Have you tried to update the reference index? Sometimes this solves such errors...

#2

Updated by X B 5 months ago

Hello,

Thanks for you answer.
How can I update the reference index ?
It may be the first step :)

Thanks

#3

Updated by Dave Zen 5 months ago

try to run

php ./typo3/sysext/core/bin/typo3 referenceindex:update

on the CLI (https://docs.typo3.org/m/typo3/guide-installation/master/en-us/Upgrade/UpdateReferenceIndex/Index.html)

Not sure if it will work on TYPO3 7 but I think it should.

Here's the documentation for TYPO3 7 on the reference index update process: https://docs.typo3.org/m/typo3/guide-installation/7.6/en-us/Upgrade/UpdateReferenceIndex/Index.html

#4

Updated by Christian Kuhn 5 months ago

  • Status changed from New to Needs Feedback

v7 has lots of issues with workspaces in combination with images/FAL.
We solved a lot of that lately, especially in v10, and we're further improving the situation in v11. Please consider updating to at least v10, it works much better in this regard.

#5

Updated by Rachel Foucard 5 months ago

Hello Christian,

I know that this ticket is about the version 7 but reading your last answer, should we understand that the V9 is not covered by the last workspaces bug fixing? I thought that the v9 is still in bugfixes phase?

thank you in advance for your answer,
Rachel

#6

Updated by Benni Mack 4 months ago

Rachel Foucard wrote in #note-5:

I know that this ticket is about the version 7 but reading your last answer, should we understand that the V9 is not covered by the last workspaces bug fixing? I thought that the v9 is still in bugfixes phase?

Hey Rachel,

the main issue is: in TYPO3 v10 we did some major refactoring under-the-hood for workspaces (for example: "pid=-1" does not exist anymore), this solves some conceptual flaws which are not possible to fix in v9. Such drastic changes (we have another bunch of functionality fixed in TYPO3 v11 regarding newly created, moved records and deleted records in workspaces, also related to the refindex) allow us to finally fix even more of workspace-related issues, which were never fixed in the past 10 years, because nobody thought of streamlining the underlying concepts.

We also have roughly 800 functional tests in workspaces, which take the majority of the time to fix when doing workspace-related changes, and with the majority of the time, I mean: multiple days of work to only do the backports and adapt the tests there. I'd therefore rather strive to fix most of the workspace issues in newer TYPO3 Core versions than to concentrate on bringing such changes back to v9, which is in fact "critical and security-related bugfixes" mode, and not fixing all issues in v9 as well.

Also available in: Atom PDF