Bug #93699

begroup pagetypes_select always has validation error

Added by Jörn Wagner 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2021-03-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since 10.4.13 it's not possible to add new page types to a backend group because checking any checkbox will result in a client-side validation error and block saving. See attached video.

Downgrading to 10.4.12 solves the issue. Related to #93574?


Files

typo3_bug_seitentypen.mp4 (165 KB) typo3_bug_seitentypen.mp4 Jörn Wagner, 2021-03-10 13:54
typo3_ticket93699.png (36.3 KB) typo3_ticket93699.png Jörn Wagner, 2021-03-10 21:26

Related issues

Related to TYPO3 Core - Bug #93574: TCA group db with minitems = 1 cannot be fulfilledClosedAndreas Fernandez2021-02-23

Actions
Related to TYPO3 Core - Bug #93728: be_groups[pagetypes_select] allows up to 20 page types onlyClosed2021-03-13

Actions
#1

Updated by Georg Ringer 7 months ago

  • Related to Bug #93574: TCA group db with minitems = 1 cannot be fulfilled added
#2

Updated by Andreas Fernandez 7 months ago

  • Assignee set to Andreas Fernandez
#3

Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68311

#4

Updated by Gerrit Code Review 7 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68318

#5

Updated by Andreas Fernandez 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Jörn Wagner 7 months ago

Andreas Fernandez wrote in #note-5:

Applied in changeset 21fb18554f5c58911972a697b3fa0c9a95f991be.

This change doesn't solve the problem for pagetypes_select though, because they have a value:

#7

Updated by Andreas Fernandez 7 months ago

Alright, I see. The issue is not that the validation per-se is broken, but there is (for whatever reason) a limit of maximum 20 allowed items defined in TCA. A quickfix to solve this in your case is to override that specific TCA:

unset($GLOBALS['TCA']['be_groups']['pagetypes_select']['config']['maxitems']);
#8

Updated by Jörn Wagner 7 months ago

Andreas Fernandez wrote in #note-7:

Alright, I see. The issue is not that the validation per-se is broken, but there is (for whatever reason) a limit of maximum 20 allowed items defined in TCA. A quickfix to solve this in your case is to override that specific TCA:

Ah. We have like 35 custom page types. Thanks, I'll include that in case it ever breaks again.

#9

Updated by Andreas Fernandez 7 months ago

  • Related to Bug #93728: be_groups[pagetypes_select] allows up to 20 page types only added
#10

Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF