Bug #93574

TCA group db with minitems = 1 cannot be fulfilled

Added by Rico Drexler 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2021-02-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

I have a TCA field with minitems = 1 (test) and a field with minitems = 1 and size = 1 (test_size).

        'test' => [
            'exclude' => true,
            'label' => 'Test with minitems',
            'config' => [
                'type' => 'group',
                'internal_type' => 'db',
                'allowed' => 'pages',
                'minitems' => 1,
            ],
        ],
        'test_size' => [
            'exclude' => true,
            'label' => 'Test with minitems (size 1)',
            'config' => [
                'type' => 'group',
                'internal_type' => 'db',
                'allowed' => 'pages',
                'minitems' => 1,
                'size' => 1,
            ],
        ],

With the TCA field "test" the condition only becomes true if you click on the word "Spielwiese", otherwise you cannot save. (see image)

With the TCA field "test_size" I have not found a way to fulfill the condition, so you can never save the entry.

I only have this bug in version 10.4.13. The bug does not exist in version 10.4.12.


Files

minitems_bug.PNG (11.5 KB) minitems_bug.PNG Rico Drexler, 2021-02-23 13:07

Related issues

Related to TYPO3 Core - Bug #93699: begroup pagetypes_select always has validation errorClosedAndreas Fernandez2021-03-10

Actions
#1

Updated by Torben Hansen 5 months ago

  • Category set to FormEngine aka TCEforms
  • Is Regression set to Yes
#3

Updated by varioous OG 5 months ago

Can confirm this since 10.4.13.
Also in FlexForm configured Custom Content Elements this happens.

<icon>
    <TCEforms>
        <label>Icon</label>
        <config>
            <type>group</type>
            <internal_type>db</internal_type>
            <appearance>
                <elementBrowserType>file</elementBrowserType>
                <elementBrowserAllowed>png,svg</elementBrowserAllowed>
            </appearance>
            <allowed>sys_file</allowed>
            <size>1</size>
            <minitems>0</minitems>
            <maxitems>1</maxitems>
            <show_thumbs>1</show_thumbs>
        </config>
    </TCEforms>
</icon>
#4

Updated by Daniel Goerz 5 months ago

  • Description updated (diff)
#5

Updated by Hannes Bochmann 5 months ago

Can confirm, too. Switching from minitems=1 to eval=required is a workaround for the moment.

#6

Updated by Oliver Eglseder 5 months ago

+1 in FlexForms, but eval=required does not work as a workaround here. Also, maxitems=1 makes the validation fail.

#7

Updated by Peter Kraume 5 months ago

I can also confirm this issue. Downgrading to 10.4.12 solves the problem.

#9

Updated by Andreas Fernandez 5 months ago

  • Assignee set to Andreas Fernandez
#10

Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68257

#11

Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68257

#12

Updated by Jörn Wagner 5 months ago

Oliver Eglseder wrote in #note-6:

+1 in FlexForms, but eval=required does not work as a workaround here. Also, maxitems=1 makes the validation fail.

Can confirm as well in 10.4.13 and downgrading to 10.4.12 helps. We need both minitems=1 and maxitems=1 for several elements.

#13

Updated by Gerrit Code Review 5 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68316

#14

Updated by Andreas Fernandez 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Georg Ringer 5 months ago

  • Related to Bug #93699: begroup pagetypes_select always has validation error added
#16

Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF