Bug #93860

Online media helpers (YouTubeHelper, VimeoHelper) preview images unusable in composer mode

Added by Jan Kornblum 6 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2021-04-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When in composer mode, the online media helpers create preview images in locations like "./var/transient/youtube_1e65d7002154f3586b97bd19d2787829.jpg". But this files can't be accessed from e.g. "<f:image>" any longer, because "ResourceFactory::retrieveFileOrFolderObject()" wrongly returns a (non existing) folder object instead of file object. This is the case because "ResourceFactory::retrieveFileOrFolderObject()" uses "Environment::getPublicPath()" in behind but paths like "/var/transient/" are not public.

Steps to reproduce:

  • Upload any youtube or vimeo video from backend
  • Assign it to any record or model
  • In FLUID, let it be rendered using "<f:image>" (when using "image" instead of "media" viewhelper, this automatically reads or creates the thumbnail)

This crashes the frontend.

Solution: Let the online media helpers create the preview images not inside "/var/transient" but in a real "public" path instead.


Related issues

Related to TYPO3 Core - Bug #93823: ResourceFactory::retrieveFileOrFolderObject() wrongly returns Folder instead of File objectNew2021-03-26

Actions
Related to TYPO3 Core - Feature #84545: Use dynamic path for typo3temp/var/ClosedBenni Mack2018-03-28

Actions
Related to TYPO3 Core - Bug #72822: Move all typo3temp files below typo3temp/var or typo3temp/assetsClosed2016-01-19

Actions
Related to TYPO3 Core - Task #72580: Move publicly accessible files to typo3temp/assets/ClosedBenni Mack2016-01-08

Actions

Also available in: Atom PDF