Project

General

Profile

Actions

Bug #93930

closed

Copy of CE with translation leads to duplicates

Added by David Hedden about 3 years ago. Updated about 3 hours ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2021-04-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

Copying a element with a translation to another language also copies other translations of that element.
This can lead to duplicate elements within one language.

Steps to recreate:
- New installation with 2 Languages
- Create a page with one text element
- Translate the page in one language and translate with connected mode
- Translate the page with the second language
- Copy text element from default to the second page translation

Result is that the first translation has the text element twice. The duplicate has the l18n_parent set to the copied Element.

This Bug is also present in 9.5.


Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Bug #82314: Copying content to other language creates duplicatesNew2017-09-06

Actions
Actions #1

Updated by Riccardo De Contardi about 3 years ago

Is this related? #82314

Actions #2

Updated by Georg Ringer about 3 years ago

  • Related to Bug #82314: Copying content to other language creates duplicates added
Actions #3

Updated by Jo Hasenau about 3 years ago

It should not be possible to copy elements from any language to a target language other than default while in connected mode.

Reason: In connected mode, the default language has got the lead over each target language. So each and every element that should be present in the target language needs a parent element in the default language.

So the bug in this case is not the behaviour after the copy action, but that the copy action is possible in the first place.

Actions #4

Updated by Riccardo De Contardi about 3 hours ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

I close this issue as actually it is a duplicate of #82314 please continue the discussion there; thank you.

Actions

Also available in: Atom PDF