Project

General

Profile

Actions

Bug #93968

closed

false order of localized CE in BE view / "Translate" button is shown but no translateable CE are available

Added by David Menzel about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2021-04-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

An editor noticed a false order of the content elements in the backend page view after a localization.

Two languages are available (de, fr) and one additional language (en) has been created. The content elements from the German language were localized to English. After that the order in the localized language (English) was wrong, the first content item of the main column was displayed at the last position in that column in the BE view. The display in the frontend is not affected.

Additionally, the "Translate" button is also displayed above the column. If you click on it, the translation dialog starts but there are no new content items for localization available. If you click "Next" the translation "starts" and shows "Verarbeitung läuft..." but this never ends.

Whether these two errors are related, I can not tell.

TYPO3 10.4.15


Files

endless loop.JPG (22.8 KB) endless loop.JPG David Menzel, 2021-04-22 13:02

Related issues 6 (1 open5 closed)

Related to TYPO3 Core - Bug #86059: Wrong sorting for localized entries in page module with 8.7.16 and higherClosed2018-08-31

Actions
Related to TYPO3 Core - Bug #83079: wrong sorting of content elements when translating using non-default-language CEs as sourceClosed2017-11-24

Actions
Related to TYPO3 Core - Bug #83469: Translation of translations break sorting in tt_contentClosed2018-01-04

Actions
Related to TYPO3 Core - Task #85300: Improve record sorting performanceClosed2018-06-18

Actions
Related to TYPO3 Core - Bug #84951: Localization: Copying new record in existing localization has off-by-one issueClosed2018-05-09

Actions
Related to TYPO3 Core - Bug #101639: false order of localized CE in BE viewNew2023-08-09

Actions
Actions #1

Updated by Riccardo De Contardi almost 3 years ago

  • Related to Bug #86059: Wrong sorting for localized entries in page module with 8.7.16 and higher added
Actions #2

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #83079: wrong sorting of content elements when translating using non-default-language CEs as source added
Actions #3

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #83469: Translation of translations break sorting in tt_content added
Actions #4

Updated by Christian Kuhn over 2 years ago

  • Related to Task #85300: Improve record sorting performance added
Actions #5

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #84951: Localization: Copying new record in existing localization has off-by-one issue added
Actions #6

Updated by Christian Kuhn over 2 years ago

  • Status changed from New to Closed

I'm quite certain we fixed that in recent v11 with one of the linked issues. I'll close the issue for now. If there is still an issue with broken language sorting in recent core v11, let's continue in a new issue.

Actions #7

Updated by Riccardo De Contardi 2 months ago

  • Related to Bug #101639: false order of localized CE in BE view added
Actions

Also available in: Atom PDF