Project

General

Profile

Actions

Bug #83079

closed

wrong sorting of content elements when translating using non-default-language CEs as source

Added by Tobias Liebig over 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2017-11-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:
  • make sure you have at least two "Website language" records (sys_language) in your root node. Let's name them "A" and "B".
  • open the page modul
  • create a blank page
  • create at least three distinct content elements in the default language. Lets name them "1", "2", "3", "4"
  • choose the "Language" view in the "actionMenu" dropdown
  • create a page translation for language "A"
  • translate the content into "A" using the "translate" mode (not 'copy') * these content elements will be created in the correct order
  • create a page translation for language "B"
  • translate the content into "B" using the "translate" mode (not 'copy')
  • choose "A" as translation source for your translation when the dialog asks "Choose the language from which you want to localize the content"
  • the order for "B" will result in "1", "4", "3", "2"

What happens:
The "localize" method in \TYPO3\CMS\Core\DataHandling\DataHandler calls "getPreviousLocalizedRecordUid" to determine after which CE the new translated CE should be placed.
This works okay for the first case (using default as source), but returns a wrong value, when using another translation as source.


Related issues 9 (2 open7 closed)

Related to TYPO3 Core - Bug #30469: Sorting of localized tt_content elements is wrong after copyingClosedStanislas Rolland2011-09-30

Actions
Related to TYPO3 Core - Bug #68040: Inline localize and/or synchronize does not respect sortingUnder Review2018-03-142018-03-14

Actions
Related to TYPO3 Core - Bug #83469: Translation of translations break sorting in tt_contentClosed2018-01-04

Actions
Related to TYPO3 Core - Task #96035: More deterministic functional test DataSetClosed2021-11-18

Actions
Related to TYPO3 Core - Bug #84951: Localization: Copying new record in existing localization has off-by-one issueClosed2018-05-09

Actions
Related to TYPO3 Core - Bug #78220: Translate mode copy does not respect orderClosed2016-10-10

Actions
Related to TYPO3 Core - Bug #81328: Translation didn't sort Elements correct. Needs Feedback2017-05-24

Actions
Related to TYPO3 Core - Bug #93968: false order of localized CE in BE view / "Translate" button is shown but no translateable CE are availableClosed2021-04-22

Actions
Related to TYPO3 Core - Bug #86059: Wrong sorting for localized entries in page module with 8.7.16 and higherClosed2018-08-31

Actions
Actions #1

Updated by Tobias Liebig over 6 years ago

Occurs in TYPO 8.7.8 and master.
From reading the code, it also might happen in earlier versions, too.

Patch already exists (will share it as soon as i figured out how to test it).
Tests are wip.

Actions #2

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #3

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #4

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #5

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #6

Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #7

Updated by Tobias Liebig over 6 years ago

  • Related to Bug #30469: Sorting of localized tt_content elements is wrong after copying added
Actions #8

Updated by Gerrit Code Review over 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #9

Updated by Susanne Moog about 6 years ago

  • Related to Bug #68040: Inline localize and/or synchronize does not respect sorting added
Actions #10

Updated by Gerrit Code Review about 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #11

Updated by Gerrit Code Review almost 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #12

Updated by Gerrit Code Review almost 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #13

Updated by Deleted Account almost 6 years ago

This seems to be broken in TYPO3 7.6 too.
Is this going to be backported?

Actions #14

Updated by Gerrit Code Review almost 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #15

Updated by Gerrit Code Review almost 6 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #16

Updated by Tymoteusz Motylewski almost 6 years ago

  • Related to Bug #83469: Translation of translations break sorting in tt_content added
Actions #17

Updated by Gerrit Code Review over 5 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #18

Updated by Gerrit Code Review over 5 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #19

Updated by Gerrit Code Review over 5 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54750

Actions #20

Updated by Gerrit Code Review over 4 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #21

Updated by Gerrit Code Review over 4 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #22

Updated by Gerrit Code Review over 4 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #23

Updated by Gerrit Code Review over 4 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #24

Updated by Gerrit Code Review over 4 years ago

Patch set 19 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #25

Updated by Gerrit Code Review about 4 years ago

Patch set 20 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #26

Updated by Gerrit Code Review over 2 years ago

Patch set 21 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #27

Updated by Gerrit Code Review over 2 years ago

Patch set 22 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #28

Updated by Gerrit Code Review over 2 years ago

Patch set 23 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #29

Updated by Gerrit Code Review over 2 years ago

Patch set 24 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #30

Updated by Gerrit Code Review over 2 years ago

Patch set 25 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #31

Updated by Christian Kuhn over 2 years ago

  • Related to Task #96035: More deterministic functional test DataSet added
Actions #32

Updated by Gerrit Code Review over 2 years ago

Patch set 26 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #33

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #84951: Localization: Copying new record in existing localization has off-by-one issue added
Actions #34

Updated by Gerrit Code Review over 2 years ago

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #35

Updated by Gerrit Code Review over 2 years ago

Patch set 28 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #36

Updated by Gerrit Code Review over 2 years ago

Patch set 29 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #37

Updated by Gerrit Code Review over 2 years ago

Patch set 30 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #38

Updated by Gerrit Code Review over 2 years ago

Patch set 31 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #39

Updated by Gerrit Code Review over 2 years ago

Patch set 32 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/54750

Actions #40

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72254

Actions #41

Updated by Christian Kuhn over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #42

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #78220: Translate mode copy does not respect order added
Actions #43

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #81328: Translation didn't sort Elements correct. added
Actions #44

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #93968: false order of localized CE in BE view / "Translate" button is shown but no translateable CE are available added
Actions #45

Updated by Christian Kuhn over 2 years ago

  • Related to Bug #86059: Wrong sorting for localized entries in page module with 8.7.16 and higher added
Actions #46

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF