Bug #93989

Global Sysfolders + Contents are not translatable anymore since TYPO3 10

Added by André Buchmann 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2021-04-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

For multitree instances we often used a global sysfolder to store some global informations (cookie services, subsidiaries, news,...). Up until TYPO3 9 the sysfolder and its contents could be translated if there were language records on pid 0.
Starting form TYPO3 10, the site configuration is checked also for available translations. As there is no site configuration for the sysfolder it won't be translatable anymore.

Please see attached screenshots which are showing the difference.


Files

typo3_11.png (55 KB) typo3_11.png André Buchmann, 2021-04-26 14:10
typo3_9.png (76.4 KB) typo3_9.png André Buchmann, 2021-04-26 14:10
folder-site-configuration.png (12.3 KB) folder-site-configuration.png Unassigned site configurations Daniel Haupt, 2021-07-15 13:17
#1

Updated by André Buchmann 7 months ago

  • Subject changed from Global Sysfolders + Contents are not translatable anymore sind TYPO3 10 to Global Sysfolders + Contents are not translatable anymore since TYPO3 10
#2

Updated by Martin Kutschker 7 months ago

Bite the bullet and create a dummy site configuration with all the required languages.

#3

Updated by André Buchmann 7 months ago

I can live with creating a Dummy site config for those sysfolders. But I was wondering if this was an intended change or happened by accident due to some refactoring?

@core-devs: if this was an intended change, just close this issue ;-)

#4

Updated by Georg Ringer 7 months ago

  • Status changed from New to Closed

closing the issue. this is intended and it might be that it will be even more restricted in future

#5

Updated by Daniel Haupt 5 months ago

Georg Ringer wrote in #note-4:

closing the issue. this is intended and it might be that it will be even more restricted in future

Issue #90948 seems to be related or targeting the same issue.

Changelog v9.4:

In case no site configuration has been created for a tree, all language records are shown. (https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/9.4/Feature-85164-AvailableLanguagesRespectsSiteConfigurationSettings.html)

So creating a dummy site configuration is the intended new way?

Thge Site configuration is automatically created for new pages on root level (https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/10.1/Feature-89142-CreateSiteConfigurationIfPageIsCreatedOnRootLevel.html). This could be done for folders too, right?

#6

Updated by Daniel Haupt 5 months ago

In Addition, the "dummy site configuration" works but does not seem to be supported for folders (page doktype = 254).

Also available in: Atom PDF