Bug #94603

int-validation in TCA does not accept empty value, when lower-range is defined

Added by Tina Westner 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2021-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

This bug came with TYPO3 10.4.18, have not checked in V11 yet.

When in tca a validation like below is given, an empty value is not accepted anymore:

'config' => [
   'eval' => 'int',
   'range' => [
       'lower' => mktime(0, 0, 0, date('m'), date('d'), date('Y'))
   ],
]

before: an empty field has been accepted and a value, which matches the lower-definition
now: if you leave the field empty, it will be prefilled with the minimum value (in this case is "now")

Can be seen in all powermail-tables for example - if you save a form, in the form-record and the pages-record the starttime and endtime-fields are set with "now".


Related issues

Is duplicate of TYPO3 Core - Bug #94621: startime/endtime are forced to "today" after savingClosed

Actions
#1

Updated by Marcus Schwemer 3 months ago

I can confirm this behavior.

#3

Updated by Marcus Schwemer 3 months ago

  • Is Regression set to Yes
#4

Updated by Christian Kuhn 3 months ago

  • Is duplicate of Bug #94621: startime/endtime are forced to "today" after saving added
#5

Updated by Christian Kuhn 3 months ago

Confirmed. Thanks for report. We got another report as duplicate with a bit more explanation and scenario description. I'll close here and we'll follow-up in #94621.

#6

Updated by Christian Kuhn 3 months ago

  • Status changed from New to Closed
#7

Updated by Oliver Hader 3 months ago

  • Category set to DataHandler aka TCEmain

Also available in: Atom PDF