Bug #94801

Updating from TYPO3 9.5.27 to 9.5.28+ leads to timeout in upgrade wizards check and reports module

Added by Florian Seirer 2 months ago. Updated 12 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2021-08-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After upgrading from TYPO3 9.5.27 to 9.5.28+, opening the reports module on our biggest site (260k+ files) leads to a timeout (set to 60 seconds in our current setup). Same thing happens in the install tool: Upgrades > Run upgrade wizards.
Our smaller sites are not affected by this.

I did some digging and I out found that disabling the new SVG sanitizer (Introduced in 9.5.28, see https://github.com/typo3/typo3/commit/0443b66463) upgrade wizard "solves" the problem, and the reports module as well as the upgrade wizard view in the install tool are working again.

Commenting out that new line in /typo3/sysext/install/ext_localconf.php works for me for now, as we don't have SVG/HTML files inside /fileadmin/, and SVG/HTML uploads are denied through [BE][fileDenyPattern].

Of course we could just raise the PHP max_execution_time, but it'd be nice if someone could look into this...


Related issues

Related to TYPO3 Core - Bug #94636: Upgrade Wizard does not loadAccepted2021-07-26

Actions
#1

Updated by Georg Ringer 2 months ago

  • Related to Bug #94787: Tracking issue related to HTML sanitization issues added
#2

Updated by Georg Ringer 2 months ago

  • Related to deleted (Bug #94787: Tracking issue related to HTML sanitization issues)
#3

Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70448

#4

Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70448

#5

Updated by Georg Ringer 2 months ago

  • Related to Bug #94636: Upgrade Wizard does not load added
#6

Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 11.3 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70532

#7

Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70533

#8

Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70534

#9

Updated by Georg Ringer 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack 12 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF