Bug #94823

Bug #94787: Tracking issue related to HTML sanitization issues

Bug #94776: Email Links with config.spamProtectEmailAddresses = 2 do not work after Update

sanitizeHtml disables email when config.spamProtectEmailAddresses is enabled

Added by Stefan Terborg 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-08-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After update to TYPO3 10.4.19 I discovered that email addresses where not properly rendered. The href attribute is missing.

The problem occurs with the following TypoScript settings:
  • config.spamProtectEmailAddresses != 0
  • lib.parseFunc.htmlSanitize = 1
  • lib.parseFunc_RTE.htmlSanitize = 1

When disabling spamProtectEmailAddresses or htmlSanitize the function works as expected.

The problem seems not to occur in fluid view helpers.

#1

Updated by Stefan Terborg 4 months ago

Duplicate of #94776

#2

Updated by Oliver Hader 4 months ago

  • Parent task set to #94776
#3

Updated by Oliver Hader 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF