Project

General

Profile

Actions

Bug #95512

closed

Routing: SimpleEnhancer stopped working with 9.5.31

Added by Rainer Becker almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-10-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since the latest upgrade my AliasMappingConfiguration does not work anymore. Configuration is like this:

  Events:
    type: Simple
    limitToPages:
      - 123
    routePath: '/{eventalias}'
    _arguments:
      event: eventalias
    aspects:
      eventalias:
        type: PersistedAliasMapper
        routeFieldName: slug
        routeValuePrefix: ''
        tableName: tx_myextension_domain_model_event

Page [123] is resolved correctly, but the parameter "event" is not added anymore. Until 9.5.29 my configuration worked.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91447: SimpleEnhancer don't inflate nested argumentsClosed2020-05-20

Actions
Actions #1

Updated by Benni Mack almost 3 years ago

  • Related to Bug #91447: SimpleEnhancer don't inflate nested arguments added
Actions #2

Updated by Benni Mack almost 3 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Oliver Hader almost 3 years ago

Rainer Becker wrote:

Since the latest upgrade my AliasMappingConfiguration does not work anymore. Configuration is like this:

[...]

Page [123] is resolved correctly, but the parameter "event" is not added anymore. Until 9.5.29 my configuration worked.

Can you please be more specific about that? Is event missing internally in your controller, or in generated URIs?

In case you want to expose route parameter eventalias to internal query param event, the mapping should be

_arguments:
  eventalias: event
Actions #4

Updated by Oliver Hader almost 3 years ago

  • Status changed from Accepted to Needs Feedback
Actions #5

Updated by Rainer Becker almost 3 years ago

Switching _argument key and value like proposed solved this. I stumbled upon this because the configuration worked with the versions before 9.5.31.
Thank you, ticket can be closed.

Actions #6

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

@Rainer Becker thank you for your reply.

Closing the issue in agreement with the reporter.

If you think that this is the wrong decision or experience the issue again please reopen it or open a new issue with a reference to this one.

Thank you.

Actions

Also available in: Atom PDF