Project

General

Profile

Actions

Bug #96512

closed

Still duplicate PageTree since 10.4.22 / 11.5.4 for some cases

Added by Franz Kugelmann over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2022-01-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

This is a followup on #96367, since that is marked as "Resolved" already.

It is still broken under certain conditions. Applies still for the newly released versions 10.4.23 and 11.5.5.
How to reproduce:
1. Create a tree with pages "Main Area" and "Sub Area" as child of "Main Area". Add some childs to "Sub Area".
2. Create two be_groups ("Main Area" and "Sub Area" and set the DB Mount Points to the matching pages, also set at least read rights for table pages).
3. Use the access module to make sure anybody has at least read rights to the whole page tree (or set rights according to the matching groups)
4. Create an editor who has both groups and log in with this editor.

You see the attached tree with duplicates.

Also attached a full page tree export with the whole test setup.


Files


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #96367: Duplicate pages in pagetree since v10.4.22Closed2021-12-16

Actions
Has duplicate TYPO3 Core - Bug #97774: Page Tree shows duplicated pages if an editor receives inherited db mounts from multiple groupsClosed2022-06-15

Actions
Actions #1

Updated by Franz Kugelmann over 2 years ago

  • Related to Bug #96367: Duplicate pages in pagetree since v10.4.22 added
Actions #2

Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #3

Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #4

Updated by Sebastian Lechenbauer about 2 years ago

Patch set 2 works for me as expected (tested in TYPO3 version 10.4.28).

Actions #5

Updated by Nikita Hovratov almost 2 years ago

  • Related to Bug #97774: Page Tree shows duplicated pages if an editor receives inherited db mounts from multiple groups added
Actions #6

Updated by Nikita Hovratov almost 2 years ago

  • Related to deleted (Bug #97774: Page Tree shows duplicated pages if an editor receives inherited db mounts from multiple groups)
Actions #7

Updated by Nikita Hovratov almost 2 years ago

  • Has duplicate Bug #97774: Page Tree shows duplicated pages if an editor receives inherited db mounts from multiple groups added
Actions #8

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #9

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #10

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #11

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #12

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #13

Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74258

Actions #14

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75223

Actions #15

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75224

Actions #16

Updated by Nikita Hovratov almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #17

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75223

Actions #18

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75224

Actions #19

Updated by Nikita Hovratov almost 2 years ago

  • Status changed from Under Review to Resolved
Actions #20

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 3 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75224

Actions #21

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75224

Actions #22

Updated by Nikita Hovratov almost 2 years ago

  • Status changed from Under Review to Resolved
Actions #23

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF