Project

General

Profile

Actions

Bug #96367

closed

Duplicate pages in pagetree since v10.4.22

Added by Michael Voehringer over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2021-12-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since TYPO3 v10.4.22 all pages are show double in the page tree for users that have mounted the tree multiple times.

How to reproduce the problem:
  1. create a group with a db mount to root
  2. assign the new group to a admin user
  3. check the pagetree

Files

duplicate-pages.jpg (25.5 KB) duplicate-pages.jpg Michael Voehringer, 2021-12-16 10:39
user-group.jpg (88.6 KB) user-group.jpg Michael Voehringer, 2021-12-16 10:39
T3D_tree_PID0_L999_2022-01-11_10-30.xml (58.9 KB) T3D_tree_PID0_L999_2022-01-11_10-30.xml Franz Kugelmann, 2022-01-11 10:35
typo3-pagetree-duplicates.png (21 KB) typo3-pagetree-duplicates.png Franz Kugelmann, 2022-01-11 10:35
clipboard-202202231443-hpryh.png (9.2 KB) clipboard-202202231443-hpryh.png Anonymous, 2022-02-23 13:43

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #96359: Mount points for editors ordering doesn't work anymore - Regression in TYPO3 10.4.22Closed2021-12-15

Actions
Related to TYPO3 Core - Bug #95854: Virtual root page is not shown when in workspace (or group mounts)Closed2021-11-03

Actions
Related to TYPO3 Core - Bug #96512: Still duplicate PageTree since 10.4.22 / 11.5.4 for some casesClosed2022-01-11

Actions
Actions #1

Updated by Michael Voehringer over 2 years ago

  • Related to Bug #96359: Mount points for editors ordering doesn't work anymore - Regression in TYPO3 10.4.22 added
Actions #2

Updated by Helmut Hummel over 2 years ago

  • Is Regression set to Yes
Actions #3

Updated by Helmut Hummel over 2 years ago

  • Related to Bug #95854: Virtual root page is not shown when in workspace (or group mounts) added
Actions #4

Updated by Helmut Hummel over 2 years ago

Regression introduced with #95854

Actions #5

Updated by Helmut Hummel over 2 years ago

  • Status changed from New to Accepted
Actions #6

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72812

Actions #7

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72835

Actions #8

Updated by Benjamin Franzke over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72816

Actions #10

Updated by Benjamin Franzke over 2 years ago

  • Status changed from Under Review to Resolved

Updated by Franz Kugelmann over 2 years ago

This is still broken under certain conditions. Applies for the newly released versions 10.4.23 and 11.5.5.
How to reproduce:
1. Create a tree with pages "Main Area" and "Sub Area" as child of "Main Area". Add some childs to "Sub Area".
2. Create two be_groups ("Main Area" and "Sub Area" and set the DB Mount Points to the matching pages, also set at least read rights for table pages).
3. Use the access module to make sure anybody has at least read rights to the whole page tree (or set rights according to the matching groups)
4. Create an editor who has both groups and log in with this editor.

You see the attached tree with duplicates.

Also attached a full page tree export with the whole test setup.

Actions #12

Updated by Franz Kugelmann over 2 years ago

  • Related to Bug #96512: Still duplicate PageTree since 10.4.22 / 11.5.4 for some cases added
Actions #13

Updated by Anonymous over 2 years ago

Same here with TYPO3 10.4.25 and 11.5.7

(tested with Tree from #96367-11)

Actions #14

Updated by Patrick Gaumond over 2 years ago

Just want to confirm that the problem persist in 10.4.26 for Editors (not Administrators).

Actions #15

Updated by Björn Heggemann about 2 years ago

  • Priority changed from Should have to Must have

Can confirm this issue with TYPO3 v10.4.27.

Actions #16

Updated by Alex Kellner almost 2 years ago

Can confirm this issue is still a problem with 10.4.31

Actions #17

Updated by Björn Heggemann almost 2 years ago

Finally, 10.4.32 solved the problem

Actions #18

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF