Project

General

Profile

Actions

Feature #96629

closed

Make "Search levels" default option configurable

Added by Christian Toffolo over 2 years ago. Updated 15 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2022-01-24
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Default option of "Search levels" in BE is "0 - This page".
Most of the time that an editor makes a search, this is not the wanted option.

An useful feature could be to make "Search levels" default option configurable.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Feature #103706: Add configuration option to allow setting a default/pre-selected option for the list view search box recursionClosed2024-04-23

Actions
Actions #1

Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79729

Actions #2

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79729

Actions #3

Updated by Gerrit Code Review 10 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79729

Actions #4

Updated by Gerrit Code Review 10 months ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79729

Actions #5

Updated by Gerrit Code Review 10 months ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79729

Actions #6

Updated by Christian Toffolo 3 months ago

I add that, at least in TYPO3 11 LTS, not only in the List Module search but also in the Link Browser search the default search level is 0 which is practically useless because the editor has to select the page/folder that contains the record it is looking for in order to find it by search and at this point the record is probably already visible. The default should be infinite levels or configurable.

Actions #7

Updated by S P 3 months ago

  • Is duplicate of Feature #103706: Add configuration option to allow setting a default/pre-selected option for the list view search box recursion added
Actions #8

Updated by Oliver Bartsch about 1 month ago

  • Status changed from Under Review to Resolved
Actions #9

Updated by Benni Mack 15 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF