Project

General

Profile

Actions

Bug #97972

closed

FlexFormTools can not be used in frontend with form framework installed

Added by David Mellen over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2022-07-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When typo3/cms-form is installed the TYPO3\CMS\Form\Hooks\DataStructureIdentifierHook is being called in FlexFormTools causing a TypeError/call on null when there is no logged in backend user, because $GLOBALS['LANG'] is called in the constructor and returns null.


Files

patch.diff (1.37 KB) patch.diff David Mellen, 2022-07-20 06:17

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #90784: Form plugin - Finishers : cannot translate "empty" value in labelsClosed2020-03-19

Actions
Related to TYPO3 Core - Task #100676: Reduce further includeLLFile usages after getLL removalClosed2023-04-20

Actions
Related to TYPO3 Core - Bug #98992: form DataStructureIdentifierHook uses $GLOBALS['LANG'] which may not be initializedClosed2022-11-03

Actions
Actions #1

Updated by Andreas Kienast over 1 year ago

  • Sprint Focus set to On Location Sprint
Actions #2

Updated by Oliver Hader over 1 year ago

  • Sprint Focus deleted (On Location Sprint)
Actions #3

Updated by Christian Kuhn 4 months ago

  • Related to Bug #90784: Form plugin - Finishers : cannot translate "empty" value in labels added
Actions #4

Updated by Christian Kuhn 4 months ago

  • Related to Task #100676: Reduce further includeLLFile usages after getLL removal added
Actions #5

Updated by Christian Kuhn 4 months ago

  • Related to Bug #98992: form DataStructureIdentifierHook uses $GLOBALS['LANG'] which may not be initialized added
Actions #6

Updated by Christian Kuhn 4 months ago

  • Status changed from New to Closed

Ok, this is still an issue in v11: The access to globals LANG in __construct() has been introduced with #90784, including v11, and has later been removed again with #100676 for v12. The hook still uses getLanguageService(), but only at deeper levels and certain circumstances.

However, I don't understand where the data structure identifier hook is called in FE at all when rendering forms, at least it wasn't triggered during tests on my side.

I tend to close the issue: I couldn't reproduce and it has been relaxed in v12. In case this is still a problem, it would be great to have insights where/why ext:form triggers that hook durnig FE rendering. Feel free to re-open or create a fresh issue if so and we'll see what we can do.

Actions

Also available in: Atom PDF