Project

General

Profile

Actions

Bug #98092

closed

Make public resource URLs better readable by default

Added by Helmut Hummel almost 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
-
Start date:
2022-08-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Instead of using a hash for public resource URLs,
now the vendor and package name should be used if possible


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #103845: Improve "_assets" composer directory migration issuesClosed2024-05-15

Actions
Actions #1

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #2

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #3

Updated by Oliver Hader over 1 year ago

  • Sprint Focus deleted (On Location Sprint)
Actions #4

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #5

Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #6

Updated by Jan Delius over 1 year ago

Is there any reason why this change is necessary/better than the current state? I really like the hash method and would hate to see this just disappear without a way to enable it via configuration.

Actions #7

Updated by Helmut Hummel over 1 year ago

Jan Delius wrote in #note-6:

Is there any reason why this change is necessary/better than the current state? I really like the hash method and would hate to see this just disappear without a way to enable it via configuration.

Interesting. Until now I only heard exactly the opposite. Can you elaborate why you like hashed folders more?

Actions #8

Updated by Jan Delius over 1 year ago

Helmut Hummel wrote in #note-7:

Interesting. Until now I only heard exactly the opposite. Can you elaborate why you like hashed folders more?

I think that's more a matter of faith, rather than people really preferring one or the other here for some reason.

I myself like that you as an end user can't see at first glance from which extensions anything is loaded. Sure, experienced users can still see something like that, but that doesn't bother either. In addition, I like when the base paths are uniformly long. But as already mentioned above, these are simply personal preferences.

As a developer, I don't see any real advantages to making the URL more readable. That's why maybe an option (in composer.json?) would be the best option here.

Actions #9

Updated by Gerrit Code Review over 1 year ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #10

Updated by Stefan Bürk over 1 year ago

  • Related to Bug #98447: Wrong symlink name for extension assets with Composer installers v4 on Windows added
Actions #11

Updated by Stefan Bürk over 1 year ago

Personally, I really loved the change to the hash. A decade old discusion with my integrator(s) ended finally and they finally have been forced to not use hardcoded paths in templates and markups. Countless debuging time of customer reported issues because of renamed images and resources and hardcoded usage in extension resources. Finally ended.

We had no issues with that in any project so far. I'm still curious if someone can really state a use-case where the revert is the only option and not only to mitigate long-term bad habits.

Actions #12

Updated by Stefan Bürk over 1 year ago

  • Related to deleted (Bug #98447: Wrong symlink name for extension assets with Composer installers v4 on Windows)
Actions #13

Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #14

Updated by Gerrit Code Review about 1 year ago

Patch set 7 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75384

Actions #15

Updated by André Buchmann 3 months ago

@Helmut Hummel Should we just abandon this patch?
We've started working on this at the dev days 2022, but it seems like there's no real interest to switch back from hashes to readable paths.

Actions #16

Updated by André Buchmann about 2 months ago

  • Status changed from Under Review to Closed

Closed in favor of better documentation of the new behavior.

See #103845
And Slack discussion: https://typo3.slack.com/archives/C03AM9R17/p1715607429453389

Actions #17

Updated by André Buchmann about 2 months ago

  • Related to Task #103845: Improve "_assets" composer directory migration issues added
Actions

Also available in: Atom PDF