Project

General

Profile

Actions

Bug #100362

closed

Issue with imageUpload and fileUpload fieds

Added by Nilesh Malankiya about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2023-03-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.1
Tags:
Complexity:
hard
Is Regression:
Yes
Sprint Focus:

Description

Facing issues while using the file upload field in Form,

$formRuntime does not return its value;

$formRuntime variable

I have checked in TYPO3 v11.5.25 it worked well.

Result of $formRuntime variable with fileUpload in V11

Can you please take a look and provide a solution before until new release?

Thanks


Files

image (1).png (25.7 KB) image (1).png Form Configure fields Nilesh Malankiya, 2023-03-31 06:01
clipboard-202303311133-fpr07.png (291 KB) clipboard-202303311133-fpr07.png $formRuntime variable Nilesh Malankiya, 2023-03-31 06:03
clipboard-202303311135-hpmbf.png (58.5 KB) clipboard-202303311135-hpmbf.png Result of $formRuntime variable with fileUpload in V11 Nilesh Malankiya, 2023-03-31 06:05
clipboard-202303311036-dditp.png (110 KB) clipboard-202303311036-dditp.png Andreas Kienast, 2023-03-31 08:36

Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Task #97214: Use uploadedFile objects instead of $_FILESClosed2022-03-20

Actions
Related to TYPO3 Core - Epic #103022: Extbase file upload handlingAccepted2024-03-31

Actions
Actions #1

Updated by Chris Müller about 1 year ago

  • Target version changed from 12.3 to 12 LTS
Actions #2

Updated by Andreas Kienast about 1 year ago

Something seems to be off, the imageupload-1 field is not within foo-210 (the form identifier), which might be the cause of the issue.

Actions #3

Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/78336

Actions #4

Updated by Andreas Kienast about 1 year ago

  • Is Regression set to Yes

This is a regression of #97214.

Actions #5

Updated by Andreas Kienast about 1 year ago

  • Related to Task #97214: Use uploadedFile objects instead of $_FILES added
Actions #6

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/78336

Actions #7

Updated by Andreas Fernandez about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Daniel Goerz 4 months ago

  • Related to Epic #103022: Extbase file upload handling added
Actions

Also available in: Atom PDF