Project

General

Profile

Actions

Bug #100766

closed

install tool is derailed by old extensions using defined('TYPO3_MODE') || die();

Added by David Bruchmann about 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2023-04-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

While it's know that TYPO3_MODE isn't used anymore in v12, it's quite common that updating extensions might be still required.
Old extensions have checks included like this:

defined('TYPO3_MODE') || die();

This is stopping TYPO3 v12 completely and never shows any hint what could be wrong. The install tool shouldn't be derailed by the missing of this constant, but scanning for it and reporting the need for removal or replacement.
Currently TYPO3 v12 is completely unusable if an extension is still having this check included.

Therefore I plead to include a definition for it at least in the install tool, so that an upgrade wizard could inform about required changes.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Task #92948: Add constant TYPO3Closed2020-11-28

Actions
Related to TYPO3 Core - Task #92947: Phase out TYPO3_MODE and friendsClosed2020-11-28

Actions
Related to TYPO3 Core - Epic #96107: Core v12 deprecation removalsClosed2021-11-21

Actions
Actions #1

Updated by David Bruchmann about 1 year ago

  • Subject changed from install tool is derailed by "TYPO3_MODE" to install tool is derailed by old extensions
  • Description updated (diff)
Actions #2

Updated by David Bruchmann about 1 year ago

  • Target version set to 12 LTS
Actions #3

Updated by Georg Ringer about 1 year ago

  • Subject changed from install tool is derailed by old extensions to install tool is derailed by old extensions using defined('TYPO3_MODE') || die();
Actions #4

Updated by Christian Kuhn about 1 year ago

the install tool does not load ext_* files from "casual" extensions, so most things of the install tool do work, including the ext scanner?!

Apart from that: we can't upgrade "wizard" this since we don't rewrite code.

Introducing that constant in any way again simply does not help us: The constant was marked deprecated, the substitution exists for two or three majors, iirc.
Extensions that did not adapt need to fail at some point. If we introduce TYPO3_MODE again for the install tool in v12, people will still not update and the issue is still shifted once again in some way for another version.

So imho: No core adaptions, but finally fix extensions!

Actions #5

Updated by Simon Gilli about 1 year ago

Actions #6

Updated by Simon Gilli about 1 year ago

  • Related to Task #92947: Phase out TYPO3_MODE and friends added
Actions #7

Updated by Simon Gilli about 1 year ago

  • Related to Epic #96107: Core v12 deprecation removals added
Actions #8

Updated by Benni Mack about 1 year ago

  • Target version changed from 12 LTS to Candidate for patchlevel
Actions #9

Updated by Riccardo De Contardi about 2 months ago

  • Status changed from New to Rejected
  • Target version deleted (Candidate for patchlevel)

Sorry but I have to close this issue as rejected.

As Christian wrote, the removal of TYPO3_MODE followed the deprecation cycle so non-compliant extensions must break and be fixed by the authors.

Actions #10

Updated by Riccardo De Contardi about 2 months ago

  • Status changed from Rejected to Closed
Actions

Also available in: Atom PDF