Project

General

Profile

Actions

Bug #100784

closed

Epic #99669: CKEditor5 Collection

CKEditor 5 - Configuration of custom CKeditor 5 plugin via RTE.editor.config.{customPlugin} not possible

Added by Reto Gehrig about 1 year ago. Updated 11 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Start date:
2023-05-10
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The configuration of own plugins for the CKeditor 5 via the TSConfig RTE.editor.config.{customer plugin} is not possible.

According to the current CKEditor5Element class, only the following options are adopted -> alignment, headings, style, table, toolbar, wordCount.

From my point of view it would be an advantage if this would be possible for own CKeditor 5 plugins. Or have I overlooked because what?


Files

javascript_exemple.png (104 KB) javascript_exemple.png Javascript Module Reto Gehrig, 2023-05-02 09:58
yaml_exemple.png (163 KB) yaml_exemple.png YAML Integration and Configuration Reto Gehrig, 2023-05-02 09:58

Subtasks 2 (0 open2 closed)

Feature #100852: Add list properties feature to CKEditorClosed2023-05-10

Actions
Task #100861: Allow to configure CKEditor "General HTML Support" pluginClosedTorben Hansen2023-05-11

Actions

Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #101437: rte_ckeditor externalPlugins with resource configuration doesn't work Closed2023-07-25

Actions
Related to TYPO3 Core - Bug #101869: CKEditor5: Pass full yaml editor configuration to CKEditor5Closed2023-09-07

Actions
Related to TYPO3 Core - Bug #102136: Revert: Enable configuration passthrough for custom CKEditor5 pluginsClosed2023-10-10

Actions
Related to TYPO3 Core - Bug #102096: CKEditor5 - Wrong id in custom element `typo3-rte-ckeditor-ckeditor5` when textfield have name with dot (.)Closed2023-10-05

Actions
Has duplicate TYPO3 Core - Bug #99535: Ckeditor5 htmlSupportClosed2023-01-13

Actions
Actions #1

Updated by Oliver Hader about 1 year ago

  • Status changed from New to Needs Feedback

See https://docs.typo3.org/c/typo3/cms-core/main/en-us//Changelog/12.0/Breaking-96874-CKEditor-relatedPluginsAndConfiguration.html

Using the YAML configuration, it is possible to inject custom plugins as ES6 modules, e.g. like this:

editor:
   importModules:
      - '@my-vendor/my-package/timestamp-plugin.js'

The configuration for using importMaps to load custom modules is documented at https://docs.typo3.org/c/typo3/cms-core/main/en-us//Changelog/12.0/Feature-96510-InfrastructureForJavaScriptModulesAndImportmaps.html and configured in EXT:my_extension/Configuration/JavaScriptModules.php

Updated by Reto Gehrig about 1 year ago

That's clear to me, it's not about integrating a plugin, but about configuration via YAML or TS configuration. See my exemple files

Actions #3

Updated by Oliver Hader about 1 year ago

  • Tracker changed from Task to Bug
  • Status changed from Needs Feedback to Accepted

Thx, Gotcha!

https://github.com/TYPO3/typo3/blob/f7751e8bc0aababd4041f79b6fa7547c3e57e90e/Build/Sources/TypeScript/rte_ckeditor/ckeditor5.ts#L104-L130 only forwards specific configuration keys.

To solve this, either a the new editor.config.settings.myExtensionButtons (new settings section) could be introduced, or all remaining keys of editor.config might be forwarded (later would allow to used all other editor config properties as well, see https://ckeditor.com/docs/ckeditor5/latest/api/module_core_editor_editorconfig-EditorConfig.html#member-users).

Actions #4

Updated by Oliver Hader about 1 year ago

  • Has duplicate Bug #99535: Ckeditor5 htmlSupport added
Actions #5

Updated by Oliver Hader about 1 year ago

  • Subtask #100847 added
Actions #6

Updated by Oliver Hader about 1 year ago

  • Subtask #100852 added
Actions #7

Updated by Oliver Hader about 1 year ago

  • Subtask #100861 added
Actions #8

Updated by Oliver Hader about 1 year ago

I've added several issues that are integrating additional/forgotten features with the own configuration scope in editor.config. Seems like forwarding all unhandled keys would be the more flexible approach, and avoids adjusting ckeditor5.ts again and again.

Actions #9

Updated by Oliver Hader about 1 year ago

  • Parent task set to #99669
Actions #10

Updated by Oliver Hader about 1 year ago

  • Status changed from Accepted to On Hold

The generic option needs further clarification, thus it's on hold for the time being.

Actions #11

Updated by Benni Mack about 1 year ago

  • Target version changed from 12 LTS to Candidate for patchlevel
Actions #12

Updated by Benjamin Franzke 12 months ago

  • Related to Bug #101437: rte_ckeditor externalPlugins with resource configuration doesn't work added
Actions #13

Updated by Georg Tiefenbrunn 11 months ago

  • Related to Bug #101869: CKEditor5: Pass full yaml editor configuration to CKEditor5 added
Actions #14

Updated by Benni Mack 10 months ago

  • Subject changed from CKEditor 5 - Configuration of customer CKeditor 5 plugin via RTE.editor.config.{customer Plugin} not possible to CKEditor 5 - Configuration of custom CKeditor 5 plugin via RTE.editor.config.{customer Plugin} not possible
Actions #15

Updated by Benjamin Franzke 10 months ago

  • Subtask deleted (#100847)
Actions #16

Updated by Benjamin Franzke 10 months ago

  • Subject changed from CKEditor 5 - Configuration of custom CKeditor 5 plugin via RTE.editor.config.{customer Plugin} not possible to CKEditor 5 - Configuration of custom CKeditor 5 plugin via RTE.editor.config.{customPlugin} not possible
Actions #17

Updated by Gerrit Code Review 10 months ago

  • Status changed from On Hold to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81381

Actions #18

Updated by Gerrit Code Review 10 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81381

Actions #19

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81388

Actions #20

Updated by Anonymous 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100
Actions #21

Updated by Oliver Hader 9 months ago

  • Related to Bug #102136: Revert: Enable configuration passthrough for custom CKEditor5 plugins added
Actions #22

Updated by Oliver Hader 9 months ago

  • Status changed from Resolved to Accepted
Actions #23

Updated by Oliver Hader 9 months ago

Reopened due to regression → see #102136

Actions #24

Updated by Gerrit Code Review 9 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81406

Actions #25

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81406

Actions #26

Updated by Christian Kuhn 9 months ago

  • Related to Bug #102096: CKEditor5 - Wrong id in custom element `typo3-rte-ckeditor-ckeditor5` when textfield have name with dot (.) added
Actions #27

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81535

Actions #28

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81535

Actions #29

Updated by Anonymous 9 months ago

  • Status changed from Under Review to Resolved
Actions #30

Updated by Benni Mack 11 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF