Project

General

Profile

Actions

Bug #101173

closed

f:asset.css -> argument "importance" is outdated

Added by Sven Juergens about 1 year ago. Updated 1 day ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Start date:
2023-06-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

hi,

could it be that, the argument "importance" in Viewhelper asset.css is outdated?
https://github.com/TYPO3/typo3/blob/03f9d4ab83ba0ba93f73fc83aeeebcd8483b4a0b/typo3/sysext/fluid/Classes/ViewHelpers/Asset/CssViewHelper.php#L94C38-L94C48

Found only that note on "importance":

Fetch Priority was first experimented with in Chrome as an origin trial in 2018 and then again in 2021 using the importance attribute.

https://web.dev/fetch-priority/#history

Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Feature #97765: [FEATURE] Add fetchpriority attribute to imagesNeeds FeedbackBenjamin Kott2022-06-13

Actions
Actions #1

Updated by Susanne Moog about 1 year ago

  • Status changed from New to Accepted

this should nowadays be the attribute fetchPriority.
We should deprecate `importance` and use fetchPriority instead.

Actions #2

Updated by Riccardo De Contardi 12 months ago

  • Category set to Fluid
Actions #3

Updated by Markus Klein 4 months ago

  • Target version set to Candidate for Major Version
Actions #4

Updated by Georg Ringer about 1 month ago

  • Sprint Focus set to On Location Sprint
Actions #5

Updated by Georg Ringer about 1 month ago

  • Related to Feature #97765: [FEATURE] Add fetchpriority attribute to images added
Actions #6

Updated by Garvin Hicking 1 day ago

With #104443 all specific registration of fluid tag attributes that are just "passed along" has ben changed. These attributes no longer are specifically registered.

Integrators using this tag would use them just as normal HTML tag attributes, beyond the scope of TYPO3 - so they either use this deprecated/outdated argument, or not. But it is no longer advocated/propagated by TYPO3/fluid.

Because of this I'm now closing this issue.

Actions #7

Updated by Garvin Hicking 1 day ago

  • Status changed from Accepted to Closed
Actions

Also available in: Atom PDF