Bug #12851


Expanding row for content element in WS module throws js error in IE6

Added by Andreas Kießling over 13 years ago. Updated almost 10 years ago.

Must have
Target version:
Start date:
Due date:
% Done:


Estimated time:
TYPO3 Version:
PHP Version:
Is Regression:
Sprint Focus:


After clicking the expand arrow in the workspace module to view difference of a content element in live ws and the current ws, i always geht a js error in IE6:

'undefined' ist Null oder kein Objekt

The MS Script Debugger points to a jsSelect function (path is not defined) in ext-all, but i think the problem is, that after clicking, the "<div id="remData[xyz]"> is not be created and so not filled with the response of the ajax request.

Actions #1

Updated by Thomas Trethan over 13 years ago

had same problem with ie7; the following workaround fixed it, though I think it is not the solution to the source of the problem (why is path undefined?):

Index: typo3/contrib/extjs/ext-all-debug.js
--- typo3/contrib/extjs/ext-all-debug.js    (revision 10523)
+++ typo3/contrib/extjs/ext-all-debug.js    (working copy)
@@ -1121,7 +1121,12 @@
             if(typeof root == "string"){
                 root = document.getElementById(root);
-            var paths = path.split(","),
+            var paths = new Array();
+            if(typeof path != "undefined") {
+                paths =  path.split(",");
+            }
                 results = [];
Actions #2

Updated by Steffen Kamper over 13 years ago

we can't patch ExtJS core.

Please apply patch from #13580 first and try again - i have the feeling that all these errors have the same source: invalid HTML

Actions #3

Updated by Andreas Kießling over 13 years ago


sorry for the late response, i did not work on that project for some weeks.

@Steffen: i updated to 4.5.3-dev from git and also to the git versions from workspaces and version where the patch you mentioned is already applied. That did not fix the issue.

Patching ExtJS however worked. Thanks Thomas!

IE (especially 6) is really a mystery. The JS engine has some big quirks and e.g. likes to loose variables. I fixed a core-bug in IE6 some time ago, where a callback function was not able to access a param that was passed to the surrounding function. Saving the param to a local variable however fixed that. Maybe something similar is going on here.

Actions #4

Updated by Tolleiv Nietsch over 12 years ago

  • Status changed from New to Needs Feedback
  • TYPO3 Version set to 4.5

Any updates for this? Any workarounds without patching ExtJs?

Actions #5

Updated by Andreas Kießling over 12 years ago

We use the patched ExtJS source since then and did not spend any more time on that.

Actions #6

Updated by Michael Stucki over 10 years ago

  • Category set to Workspaces
Actions #7

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #8

Updated by Markus Klein almost 10 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for more than 90 days, therefore closing this issue.


Also available in: Atom PDF