Bug #13554

Javascript errors in grid view in IE7

Added by Nils Blattner almost 10 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-03-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi there

Version: TYPO3 4.5.2
I just spent a lot of time fixing an issue in workspaces and would like to share my findings:

When clicking on any change in the workspace module in IE, you get an error saying "fly(...) is not an object".
This results from the function 'getTarget' of Ext.EventObject.
It does not check whether Ext.grid.GridView.fly() returns an object or not.

The reason behind this is, that the HTML that is generated for the GroupingView is not valid XHTML and therefore not parsed!
IE8, Firefox etc. ignore this and are able to work properly anyway.

There is a quick fix:
ext-all-debug.js at line 5055

getTarget : function(selector, maxDepth, returnEl){
/* MODIFIED start /
if (selector) {
var trg = Ext.fly(this.target);
if (trg) {
return trg.findParent(selector, maxDepth, returnEl);
} else {
return this.target
}
} else {
return (returnEl ? Ext.get(this.target) : this.target);
}
//return selector ? Ext.fly(this.target).findParent(selector, maxDepth, returnEl) : (returnEl ? Ext.get(this.target) : this.target);
/
MODIFIED end */
},

I also changed two JavaScripts in workspaces, however I am not sure if they actually contribute something to the solution.
They were a first attempt at fixing the issue while rendering, but didn't solve the problem.
I will find out tomorrow if they actually contribute to the solution or not.

To sum it up:

The rendered HTML must become valid XHTML.
In the mean time a modified Ext-js hides the underlying problem.

More tomorrow

Regards Nils


Related issues

Related to TYPO3 Core - Bug #26618: IE7 bug on changing block fomat (FormatBlock box)ClosedStanislas Rolland2011-05-04

Actions
Related to TYPO3 Core - Bug #26702: Action button (Publish button) is not working in workspace (IE7) Closed2011-05-09

Actions
#1

Updated by Steffen Kamper almost 10 years ago

have a look if #13580 solves this

#2

Updated by Stefan Neufeind over 9 years ago

There is a fix proposed in #26618 which is almost identical to what you proposed here.
If you can, please try if that patch fixes it for you.

#3

Updated by Tolleiv Nietsch almost 9 years ago

  • Status changed from New to Closed
  • TYPO3 Version set to 4.5

Closed due to missing feedback and due to the fact that this seems to be a duplicate anyways.

#4

Updated by Michael Stucki about 7 years ago

  • Category changed from Bugs to Workspaces
#5

Updated by Michael Stucki about 7 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF