Bug #15005

No install is possible, if in the Install-Tool multiplyDBfieldSize is set to "2"

Added by Oliver Thiele over 16 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-10-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If multiplyDBfieldSize in the Install-Tool is set to "2" there is no possibility to install DAM.
This is the Error-Message shown by the Install-Tool after the click on the +-Icon:

SQL engine parse ERROR: Field type unknown!: near "float unsigned NOT NULL default '0' "

In ext_tables.sql are two lines:
width float unsigned DEFAULT '0' NOT NULL,
height float unsigned DEFAULT '0' NOT NULL,
When i comment them out, i can install DAM with multiplyDBfieldSize = 2.

(issue imported from #M1524)


Related issues

Is duplicate of TYPO3 Core - Bug #17480: TABLE sys_refindex definition not compatible with mysql < 4.1.2ClosedMichael Stucki2007-07-17

Actions
#1

Updated by old_r3 about 16 years ago

I have the same problem.

Typo3 3.8.1
MySql 4.1.11
PHP 4.4.1

#2

Updated by Karsten Dambekalns about 16 years ago

Does this really only happen when using multiplyDBfieldSize?!

#3

Updated by old_r3 about 16 years ago

Yes, it happens when multiplyDBfieldSize >1

#4

Updated by old_heinerlamprecht about 16 years ago

It also works, when you change the datatype to double. Probably better, than removing a column from the table.

#5

Updated by Robert Markula almost 16 years ago

Confirmed as well on Typo3 4.0.

#6

Updated by René Fritz about 15 years ago

Aloha

Kannst du mir einen Hinweis geben ob das noch aktuell ist und wenn ja was ich ändern soll?

Danke und schöne Grüße
René

#7

Updated by Marc Véron about 15 years ago

Confirmation for Typo3 4.0.2

I had lots of SQL Warnings after installing DAM, e.g. using List module:
"...typo3 line 801 Warning: mysql_fetch_assoc()..."

Removed following line from localconf.php:
$TYPO3_CONF_VARS['SYS']['multiplyDBfieldSize'] = '3'; //Added MV for UTF-8

Then Database Check / Compare created missing table.

DAM works now .

#8

Updated by Christian Kuhn almost 13 years ago

Resolved as duplicate of #17480

#9

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF