Bug #15050

Gremlin: Filelist module should have "New" button

Added by Ingmar Schlecht over 15 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-10-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

At the moment, the only way to create files or folders in the Filelist module is by clicking the clickmenu.
Most newcomers seem to look for it in the module itself (right frame). Would be cool, if a "new" button could be inserted there.

(issue imported from #M1599)


Files

filesbuttons.patch (1.86 KB) filesbuttons.patch Administrator Admin, 2005-12-18 12:59
file_list-newIcon.inc.diff (975 Bytes) file_list-newIcon.inc.diff Administrator Admin, 2006-01-28 17:16
#1

Updated by Stefano Cecere over 15 years ago

i think that this feature for the BE should be really taken in consideration by the Gremlins team..

PLEASE! it's too important for usability (and not only for newcomers!)

#2

Updated by Sebastian Kurfuerst over 15 years ago

Hi,
is it possible for you to implement this as a patch?

Greets, Sebastian

#3

Updated by Stefano Cecere over 15 years ago

i'm working on it.

i made the "new" button work.. i have some problems with the "upload"...

#4

Updated by Stefano Cecere over 15 years ago

i uploaded a patch.

there was some strange (bug) behaviour in the html code of the page, that prevented my first <form> button to work.
so i had to add that <form></form>

i guess the problem is that <form> tag in the <body> element..
is it necessary?

i could not build the buttons with the simple <input type="submit" onClick="jump.....">
i could not find any doc about building the right urls, so i went with the classical <form></form> (that i like better because all the param can be well written

last thing: it was the first time i did a .patch using diff.. i hope it's ok!

i hope to get some feedfack so i can begin "hacking" the core :)

stefano

#5

Updated by Stefano Cecere over 15 years ago

a tried to delete teh unused main <form> tag of the file list frame, but it's a bit too complicated.

my patch anyway works well.

if anybody is going to review it for the core, maybe could try to clean the html

#6

Updated by Stefano Cecere over 15 years ago

i've been using heavily the UPLOAD button of my patch, and it seems to work very well (how is it possible to live without it, now? :)

#7

Updated by Martin Kutschker over 15 years ago

Uploaded a new patch that adds the usual new-element-icon (like Web>List).

#8

Updated by Stefano Cecere over 15 years ago

but so we don't have UPLOAD (like i provided in mine patch)?

i guess that UPLOAD is far more needed by normal editors, than a NEW button
anyway it's bettere than nothing :)

#9

Updated by Martin Kutschker over 15 years ago

True.

Since I like the icons because they are consistent with the UI I have to add an upload-icon as well.

#10

Updated by Stefano Cecere over 15 years ago

can you make it (the upload icon and function)?
if got no time.. use an empty one.. we'll ask the t3_skin4 team to design it better! :D

#11

Updated by Stefano Cecere over 15 years ago

ops .. obviously there is already an upload icon:

/typo3/gfx/upload.gif

#12

Updated by Stefano Cecere over 15 years ago

Hi Martin.. i thought a bit about it,and i don't think it's so a good idea to put the little icons (like in the list view) just to be UI consistent.

if you see the Page view, we have big "new page""move page" etc buttons...

and in the file module, what someone want to to is really UPLOAD something.
so i think it would be much better to put the two big buttons as with my patch.

maybe we can leave the two little icons, ok that's consistent.

what do you think?

#13

Updated by Stefano Cecere about 15 years ago

hi Ingmar.. i guess to see this patch into beta 3 ti test it, but it isn't there!

#14

Updated by Ingmar Schlecht about 15 years ago

Fixed in CVS for TYPO3 4.0.

Thanks Stefano for the patch!

cheers,
Ingmar

Also available in: Atom PDF