Bug #15579

bug on storing mm_relations

Added by Martin Ficzel almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2006-03-12
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

when i edit records with mm relations in rc1 and press save the mm-relations are deleted .. i can use the select wizzard to recreate them but after saving they are gone again

in beta2 everything is fine.

here is a tca snippet from my record configuration

"roomobjects" => Array ( "exclude" => 1, "label" => "LLL:EXT:artec_roominfo/locallang_db.php:tx_artecroominfo_signatures.roomobjects",
"config" => Array (
"type" => "group", "internal_type" => "db", "allowed" => "tx_artecroominfo_objects", "size" => 10, "minitems" => 0,
"maxitems" => 99,
"MM" => "tx_artecroominfo_signatures_objects_mm",
"wizards" => Array (
'_PADDING' => 1,
'_VERTICAL' => 0,
'_POSITION' => 'right',
'_VALIGN' => 'top',
'select' => Array(
'type' => 'popup',
'title'=> 'select from floorplan',
'icon' => 'list.gif',
'JSopenParams' => 'height=600,width=550,status=0,menubar=0,scrollbars=1',
'params' => Array ( ),
'script' => t3lib_extMgm::extRelPath("artec_roominfo").'wizards/roominfo_wizard.php',
),
),

(issue imported from #M2840)

t3lib_loaddbgroup.patch View (2.37 KB) Administrator Admin, 2006-03-16 12:12

class.t3lib_loaddbgroup.php View (17.8 KB) Administrator Admin, 2006-03-16 12:16

t3lib_tcemain.patch View (986 Bytes) Administrator Admin, 2006-03-16 14:24

class.t3lib_tcemain.php View (233 KB) Administrator Admin, 2006-03-16 14:25


Related issues

Related to TYPO3 Core - Bug #15861: Recent "fixes" in t3lib_loaddbgroup introduces potentially hard found bugs in 3rd party applications Closed 2006-03-20
Related to TYPO3 Core - Bug #16518: MM relations should be editable from both sides of the relation Closed 2006-09-01

History

#1 Updated by Rudy Gnodde almost 14 years ago

I've noticed the same thing with the tt_news plugin when selecting categories.

#2 Updated by Sacha Vorbeck almost 14 years ago

when installing the latest DAM snapshot from http://typo3lab.colorcube.de/download/dam/dam_src-20060228-01.zip the problem will be solved.

But that doesn`t look like a reliable and stable solution to me. At least it should make it easier to finde the problem.

#3 Updated by Bernhard Kraft almost 14 years ago

I found the reason for this is in the
"Improved MM handling from foreign records"
commited on Tue Mar 7 23:39:38 2006 UTC

The only later changes were related to code-cleanups so you can safely revert to
the previous version:

http://cvs.sourceforge.net/viewcvs.py/*checkout*/typo3/TYPO3core/t3lib/class.t3lib_loaddbgroup.php?rev=1.12

Rene should look what's the case here ...

#4 Updated by bartoszx almost 14 years ago

Revert to 1.12 dosn't work with 4.0rc1

#5 Updated by Erik Svendsen almost 14 years ago

Have also the same problem as Rudy.

Selected categories in a newsitem can't be saved. Using the t3 4 version of tt_news 2.2.40.

Reverting to class.t3lib_loaddbgroup-php?rev=1.12 gives following error message.

Fatal error: Call to undefined method t3lib_loadDBGroup::init() in /var/www/html/typo3_src-4.0rc1/t3lib/class.t3lib_transferdata.php on line 384

So it looks like this isn't a solution.

#6 Updated by René Fritz almost 14 years ago

The bug was introduced by me. Hooray.

The code changes allow a feature to edit a MM relation from both sides/related tables. In last minute I did some (good) code cleanups which causes this bug.

Anyway, fix is in CVS and attached as patch.

#7 Updated by René Fritz almost 14 years ago

attached full class.t3lib_loaddbgroup.php file for download.

#8 Updated by Erik Svendsen almost 14 years ago

The new class.t3lib_loaddbgroup.php doesn't solve the problem with saving categories in tt_news on my installation. Have also tried the patch with same results. But It could be me who have made a error.

So either is this another bug, or the case is more complicated.

My config: Fedora Core 4, Apache 2.0.54, PHP 5.0.4, T3 4.0rc1.

#9 Updated by René Fritz almost 14 years ago

tt_news use select field. In fact the former fix worked for group fields only. :-(
Attached patch for tcemain fix this and hopefully solve the outstanding MM problems.

#10 Updated by Erik Svendsen almost 14 years ago

Thanks Rene!!

It works fully on my installation now.

Full credit, really fast solved.

#11 Updated by bartoszx almost 14 years ago

I cant Clear cache in typo3conf after patching.

Fatal error: Call to undefined function: removecachefiles() in /home/archiwum2/archiwum/praca/source/typo3_src-4.0rc1/t3lib/class.t3lib_tcemain.php on line 4945

Can you confirm this?

#12 Updated by Erik Svendsen almost 14 years ago

Can confirm it.

Didn't test this yesterday!

#13 Updated by old_schluri almost 14 years ago

Same Problem:

Fatal error: Call to undefined function: removecachefiles() in /home/archiwum2/archiwum/praca/source/typo3_src-4.0rc1/t3lib/class.t3lib_tcemain.php on line 4945

#14 Updated by Frank Naegler almost 14 years ago

I can reproduce this problem with 4.0 RC1 on tt_news articles and categories. after downgrade to 4.0 beta3 it works fine.

#15 Updated by Kai Rudolph almost 14 years ago

Same Problem with RC1 and tt_news 2.2.40.

#16 Updated by Michael Stucki almost 14 years ago

Fixed by reverting the whole patch.

Also available in: Atom PDF