Bug #15754

The ext_typoscript_setup.txt files sometimes don't get included

Added by Ingmar Schlecht about 15 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2006-03-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Bug in t3lib_tstemplate::addExtensionStatics():

When the template having the "rootlevel" flag is not the same as the template having the "clear constants" and "clear setup" flags, the ext_typoscript_setup.txt and ext_typoscript_constants.txt don't get included.

The condition if(...&&$row['root']) should be changed to if(...&&$row['clear']&1) for the ext_typoscript_constants.txt inclusion and if(...&&$row['clear']&2) for the the ext_typoscript_setup.txt.

(issue imported from #M2747)

#1

Updated by Alexander Opitz about 8 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • PHP Version deleted (4)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF