Bug #15948

Installation blocks complete BE

Added by Steffen Kamper over 14 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
-
Start date:
2006-03-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

because the dependencies are not show, Installation of tt_products on RC2 blocks with missing dependend Ext complete BE with a Message like this:

TYPO3 Fatal Error: Extension key "table" was NOT loaded!

dependcies: table,fh_library
(issue imported from #M3064)


Related issues

Related to TYPO3 Core - Bug #15877: EM doesn't respect dependencies if no version number is specifiedClosedRobert Lemke2006-03-22

Actions
#1

Updated by Steffen Kamper over 14 years ago

seems that TER is deleting the dependencies. This differs from that one i got from TER:
http://cvs.sourceforge.net/viewcvs.py/typo3xdev/tx_ttproducts/ext_emconf.php?rev=1.51&view=markup

In my ext_emconf i received is nothing dependend etc:
'constraints' => array(
'depends' => array(
'php' => '4.2.3-',
'typo3' => '3.8.0-4.0.20',
),
'conflicts' => array(
),
'suggests' => array(
),
),

#2

Updated by Franz Holzinger over 14 years ago

This error is not in tt_products.
As you can see here the ext_emconf.php file has been correct in the past:
http://cvs.sourceforge.net/viewcvs.py/typo3xdev/tx_ttproducts/ext_emconf.php?rev=1.51&view=markup

#3

Updated by Franz Holzinger over 14 years ago

See error 0002954 which is very similar to this one.

#4

Updated by Joris Willems over 14 years ago

I had the same problem with RC2. Now I have reinstalled using RC3 and the error is no longer occuring. I think you can close this bug.

#5

Updated by Franz Holzinger over 14 years ago

The error seems to be corrected in CORE for TYPO3 4.0 RC2.

#6

Updated by Franz Holzinger over 14 years ago

This error is present again. So the error corrections did not work.

#7

Updated by Franz Holzinger over 14 years ago

Hello,
please assign this to someone else.
I do not know about EM and TER2.

A similar error happens when you install phpMyAdmin 0.2.1

The former
'version' => '0.2.1',
'constraints' => array(
'depends' => array(
'php' => '3.0.0-',
'typo3' => '3.5.0-',
),
'conflicts' => array(
),
'suggests' => array(
),
),

has been changed during download from TER2 to

'version' => '0.2.1',
'constraints' => array(
'depends' => array(
'typo3' => '0.0.2-0.0.2',
'php' => '0.0.2-0.0.2',
),
'conflicts' => array(
),
'suggests' => array(
),
),
which results in error messages in the EM:
#8

Updated by Franz Holzinger over 14 years ago

Reminder:
Please assign this to someone else.

#9

Updated by Rupert Germann over 11 years ago

cannot reproduce on current TYPO3 version.
I installed latest tt_products from TER, the dependencies to div, table and fh_library where correctly resiolved and all works.

#10

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF