Project

General

Profile

Actions

Bug #16522

closed

tx_cms_showpic (click to enlarge) not working

Added by r bhatia over 17 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2006-09-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the popup window should show an image but is giving an error instead:

Parameter Error: Wrong parameters sent.

this results from lines 134-168 in ./typo3/sysext/cms/tslib/showpic.php

to resolve this issue typo3 has to "rawurldecode" the parameters. i had to replace lines 135-145 with the following code to achieve the desired behaviour:

$this->file = rawurldecode(t3lib_div::_GP('file'));
$this->width = rawurldecode(t3lib_div::_GP('width'));
$this->height = rawurldecode(t3lib_div::_GP('height'));
$this->sample = t3lib_div::_GP('sample');
$this->alternativeTempPath = rawurldecode(t3lib_div::_GP('alternativeTempPath'));
$this->effects = rawurldecode(t3lib_div::_GP('effects'));
$this->frame = t3lib_div::_GP('frame');
$this->bodyTag = rawurldecode(t3lib_div::_GP('bodyTag'));
$this->title = rawurldecode(t3lib_div::_GP('title'));
$this->wrap = rawurldecode(t3lib_div::_GP('wrap'));
$this->md5 = t3lib_div::_GP('md5');

please commit this change for typo3 4.0.2

kind regards,
raoul bhatia

(issue imported from #M4143)

Actions #1

Updated by Michael Stucki over 17 years ago

I can't believe this is a problem, though I didn't test it. Maybe some extension is conflicting?

Can anybody confirm this problem?

Actions #2

Updated by r bhatia over 17 years ago

you can find the - now working example - at http://pfadfinder.weidling.at/

Actions #3

Updated by Administrator Admin over 17 years ago

I am having the same problem - using version 3.7.0. Replaced the code as suggested but did not solve the problem.

Regards

Hugh McKitterick

Actions #4

Updated by Michael Stucki over 17 years ago

The parameter format for the showpic document has changed since 3.7.0. You'll need to check this with 4.0.2.

Actions #5

Updated by Michael Stucki over 17 years ago

Seems like the version was not the most recent one. Otherwise please reopen.

Actions #6

Updated by r bhatia almost 17 years ago

it reappeared just now using typo3 v4.1.1.

please see http://pfadfinder.weidling.at/site/25.0.html and click any image.

the first image produces this link: http://pfadfinder.weidling.at/site/index.php?eID=tx_cms_showpic&file=uploads%2Fpics%2Fjudendorf_klausur_0706_001.jpg&width=800m&height=600m&bodyTag=%3Cbody%20style%3D%22margin%3A0%3B%20background%3A%23fff%3B%22%3E&wrap=%3Ca%20href%3D%22javascript%3Aclose%28%29%3B%22%3E%20%7C%20%3C%2Fa%3E&md5=58fe358bad469bbeed779078e8ddf4f1

i use this rewrite information:
RewriteRule ^site/index.php(.*)$ /index.php$1 [R]
RewriteRule ^site/showpic.php(.*)$ /showpic.php$1
RewriteRule ^site/([a-zA-Z0-9\-]*)([\.]*)([0-9]*)([\.]*)html([::graph::]*)$ /index.php?id=$1&type=$3&%{QUERY_STRING}

the weired thin is, it worked until recently.

kind regards,
raoul bhatia

Actions #7

Updated by r bhatia almost 17 years ago

i think i narrowed it down to the rewrite rules.

adding the following below the last rewrite url solves the problem:

RewriteRule ^([a-zA-Z0-9\-]*)([\.]*)([0-9]*)([\.]*)html([::graph::]*)$ /index.php?id=$1&L=$3&%{QUERY_STRING}

any idea on this issue?

Actions #9

Updated by Benno Weinzierl almost 16 years ago

Can reproduce this bug in V 4.2.0 in one special environment. At most Servers it works.

The MD5 Testsum is generated with rawurlencoded strings in class.tslib_content.php and testet in showpic.php with not decoded strings. As a result the md5-sums are not matching. -> error

The mentioned code fixes the issue for me too:
$this->file = rawurldecode(t3lib_div::_GP('file'));
$this->bodyTag = rawurldecode(t3lib_div::_GP('bodyTag'));
$this->title = rawurldecode(t3lib_div::_GP('title'));
$this->wrap = rawurldecode(t3lib_div::_GP('wrap'));

I dont understand why this works at all for most servers without that fix?

Actions #10

Updated by Matthias Nagl about 14 years ago

The same happened here with a brand new 4.3.3 installation!
Please commit this fix to the next official releases!! After all it is a solved problem and it is really annoying if fixes that are several years old don't make it into the official releases.

Actions #11

Updated by Jens Schmietendorf about 14 years ago

I've had the same problem that the click enlarge function doesn´t worked any longer after a page transfer to a new server.
The reason was a very long eID-GET-variable due to excessive wrapping for the click enlarge image, which get in trouble with the server config...

After outcommenting the wrap the click enlarge image worked as usual.

error.log:

FastCGI: server "/var/www/php-fastcgi/webxxx/php-fcgi-starter" stderr: ALERT - configured GET variable value length limit exceeded - dropped variable 'wrap'

Actions #12

Updated by Alexander Opitz over 10 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.0
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.1.7)?

Actions #13

Updated by Alexander Opitz about 10 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions

Also available in: Atom PDF