Feature #16617

Custom error pages

Added by John Angel over 13 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Communication
Target version:
-
Start date:
2006-10-04
Due date:
% Done:

0%

PHP Version:
4
Tags:
Complexity:
Sprint Focus:

Description

It would be nice to build custom error pages (some extern static HTML) for database connectivity problem and similar major errors.

Maybe it can be based on Dmitry's approach for 'Page not found' handling:
http://news.typo3.org/news/article/typo3-4-0-1-404

(issue imported from #M4330)


Related issues

Duplicates TYPO3 Core - Feature #17992: Add pageUnavailable_handling for system problems and maintenance Closed 2008-01-14

History

#1 Updated by Ben van 't Ende over 13 years ago

All errors are at presently converted to a 404 which is good behaviour. Only the error message is not shown. I have experienced some of these cases already. I think the way to go is still to have a customizable 404 page AND add the possibility to include a 404 message content element that shows the current error.

Possible?

gRTz

ben

#2 Updated by Dmitry Dulepov almost 12 years ago

Deassigning because I am not sure I can take care of it

#3 Updated by Steffen Kamper almost 12 years ago

this issue is solved in 4.2 by Jeff Segars.
Look to #17992

#4 Updated by Christian Kuhn almost 10 years ago

Resolved as duplicate of #17992

#5 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF