Bug #16773

Epic #65814: Make Indexed search extbase plugin shine

specConfs.[pid].CSSsuffix = xy doesn't work

Added by Typoheads - Web Engineering almost 13 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
Start date:
2006-12-08
Due date:
% Done:

100%

TYPO3 Version:
4.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

find the description of 'specConfs' here:
http://typo3.org/documentation/document-library/extension-manuals/doc_indexed_search/current/view/1/5/#id2811499

full:

plugin.tx_indexedsearch.specConfs.116.CSSsuffix = inv
plugin.tx_indexedsearch.specConfs.0.CSSsuffix = inv

typo3 v4.0.2, newest indexed_search
(issue imported from #M4626)

Associated revisions

Revision a2e088c8 (diff)
Added by Tymoteusz Motylewski over 4 years ago

[BUGFIX] Indexed_search: add CSSsufix to title class

Add missing marker and fluid expression for templates,
so the search results are rendered as documented.

Resolves: #16773
Releases: master, 6.2
Change-Id: I514f20e8802a624bf1416b9a55b90f8d3f82c1d9
Reviewed-on: http://review.typo3.org/38459
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 07c20943 (diff)
Added by Tymoteusz Motylewski over 4 years ago

[BUGFIX] Indexed_search: add CSSsufix to title class

Add missing marker and fluid expression for templates,
so the search results are rendered as documented.

Resolves: #16773
Releases: master, 6.2
Change-Id: I514f20e8802a624bf1416b9a55b90f8d3f82c1d9
Reviewed-on: http://review.typo3.org/38459
Reviewed-on: http://review.typo3.org/38522
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Christian Oettinger over 11 years ago

Same problem for pageicon for me.

A configuration like:
specConfs.16.pageIcon.file = fileadmin/gestaltung/indexed_search_icons/buch.gif
specConfs.14.pageIcon.file = fileadmin/gestaltung/indexed_search_icons/buch2.gif
uses always the icon defined for the higher pid, regardless order of configuration.
Configuration for some pages (pagetypes?) though seem to be completely ignored, I could not yet figure out which or why.

Typo3 4.1.1
indexed_search 2.10.0

#2 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.1

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Christoph Werner over 6 years ago

Hi!

I´ve just testet the css-thing:

plugin.tx_indexedsearch.specConfs.70.CSSsuffix = test
plugin.tx_indexedsearch.specConfs.0.CSSsuffix = test

but it seemed that it doesnt work.

I used TYPO3 4.5.24.

Best Regards
Chris

#4 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to New

#5 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.5
  • Is Regression set to No

#6 Updated by Tymoteusz Motylewski over 4 years ago

PIBASED plugin:

the csssuffix is available in the marker ###CSSSUFFIX###
unfortunatelly it's not present in the default template, so you have to add it yourself.
after adding the marker to the template, it works for me in TYPO3 v7

Icons works fine in v7 too.
We should check how is it in v6.2

Extbase plugin:
icons are working in 7
css suffix can be added with {row.CSSsuffix} synatx in Partials/Searchresult.html

#7 Updated by Tymoteusz Motylewski over 4 years ago

  • Parent task set to #65814

#8 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38459

#9 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38459

#10 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38459

#11 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38522

#13 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Under Review to Resolved

#14 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF