Feature #16920

Refresh left menu frame if extension with backend module was installed or removed

Added by Oliver Hader almost 13 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2007-01-30
Due date:
% Done:

0%

PHP Version:
5
Tags:
Complexity:
Sprint Focus:

Description

If an extension that contains a backend menu has been installed or was removed, the module link doesn't show up in the left menu frame. It's necessarry to reload manually to get the new module visible.

The extension manager could trigger an automatic reload if a module was installed or removed.

(issue imported from #M4886)

0004886.patch View (3.99 KB) Administrator Admin, 2007-01-30 09:28

0004886_2.patch View (5.45 KB) Administrator Admin, 2007-01-30 13:40

0004886_3.patch View (1.8 KB) Administrator Admin, 2007-02-03 17:07


Related issues

Related to TYPO3 Core - Bug #17318: TYPO3 back-end is blocked on new installations because of a bug in RFCs #15084/#15084 Closed 2007-05-19
Related to TYPO3 Core - Bug #42009: Enable extenisions with BE modules don't refresh the module list Closed 2012-10-15
Duplicates TYPO3 Core - Feature #15084: Extension Manager Feature Request: Backend Frameset does not reload when installing backend modules Closed 2005-10-17

History

#1 Updated by Oliver Hader almost 13 years ago

Please have a look at the attached file 0004886.patch and test its functionality.

#2 Updated by Peter Foerger almost 13 years ago

Works fine here on TYPO3 4.1beta3*PHP5*FF*OS X 10.4.8 !
What really annoys me is the logout/login procedure to awake the modules functionality. But this is another story.

#3 Updated by Oliver Hader almost 13 years ago

Thanks Peter for testing the patch. I had to do some small changes to the patch. For the case, requirements of an extension didn't match the restart process lead to an endless loop.
This is fixed in 0004886_2.patch.

#4 Updated by Karsten Dambekalns almost 13 years ago

~12059: You can also just reload the whole BE frameset, see also comments to #15084

#5 Updated by Oliver Hader almost 13 years ago

Karsten, thanks for the hint! A link which offers to reload the whole backend and that appears only when an extension containing modules was installed, is simple and helpful. The attached new file (0004886_3.patch) implements this feature...

#6 Updated by Ingo Renner over 12 years ago

the patch was partially used for fixing 584, so just little work is left here...

#7 Updated by Ingo Renner over 12 years ago

fixed in SVN

#8 Updated by Michael Hirdes over 12 years ago

reopened by request of Franz H.

#9 Updated by Oliver Hader over 12 years ago

@Michael: Please tell us the reason for reopening this issue. What doesn't work and how can it be reproduced?

#10 Updated by Ingo Renner over 12 years ago

fixed in SVN, if you have a problem with the solution, open a new report!

#11 Updated by Michael Stucki over 12 years ago

@Oliver: If someone needs to explain that, then it's Franz H.

However, since he already opened bug #17318 about exactly this topic, we can close this one once again.

- michael

Also available in: Atom PDF