Bug #17079

Wrong path for images in repetitive content elements

Added by Florian Busch (floxx) over 14 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-03-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If i create an repetitive fce with an image, the wrong path to the image is being set.

In database there's the absolute path to an image already saved. If i insert image in fce in backend, the path is constructed like this:
/customers/customer.de/frontend/htdocs/uploads/tx_templavoila//customers/customer.de/frontend/htdocs/fileadmin/contents/dummy_images/a2.jpg
and an error is thrown: (errno=2 - No such file or directory) in /customers/customer.de/frontend/typo3_src-4.0.5/t3lib/class.t3lib_befunc.php on line 1605
(issue imported from #M5132)


Files

ds.xml (10.7 KB) ds.xml Administrator Admin, 2007-03-05 16:45

Related issues

Related to TYPO3 Core - Bug #19716: History/Undo not works on image elementsClosed2008-12-18

Actions
Has duplicate TYPO3 Core - Bug #17321: filemtime() [function.filemtime]: stat failedClosed2007-05-22

Actions
#1

Updated by Florian Busch (floxx) over 14 years ago

Confirmed with TYPO3 4.1

#2

Updated by Petro Boychuk almost 14 years ago

Same problem with TYPO3 4.1.3 and Templavoila 1.3.1

#3

Updated by Nikolas Hagelstein almost 14 years ago

Confirmed on TYPO3 4.1.2 and TV 1.3.3

#4

Updated by Raffi no-lastname-given over 13 years ago

Confirmed in TYPO3 4.1.5 and TV 1.3.3.
The problem does not appear in TYPO3 4.1 and TV 1.3.0.

#5

Updated by Robert von Hackwitz over 13 years ago

It seems that isn't releated to templavoila but to
changes made in class.t3lib_tcemain.php from TYPO3 ver. > 4.1.1
inside method checkValue_flex_procInData_travDS.
Here are differences from 4.1.1 and 4.1.x:
@ -2130,7 +2138,11 @
if ($DSelements[$key]['section']) {
foreach($dataValues[$key]['el'] as $ik => $el) {
$theKey = key($el);
- if (is_array($dataValues[$key]['el'][$ik][$theKey]['el'])) {

// It may happen that an element exists in $dataValues but is missing in $dataValues_current. In this case, just skip the element..
.
+ $elExists = is_array($dataValues_current[$key]['el'][$ik]);

if ($elExists && is_array($dataValues[$key]['el'][$ik][$theKey]['el'])) {

...Obviously IMHO

#6

Updated by Darren Clark about 12 years ago

Confirm that this is still an issue with 4.2.8 and templavoila 1.37

A FCE which has a section which contains an image element does not work correctly, debugging the checkValue_flex_procInData_travDS method the values are present in the dataValues_current array but not handled correctly.

I'm sponsoring this fix at 100Euro to correct this issue.

Thanks in advance

#7

Updated by Nick Lobeck about 12 years ago

http://bugs.typo3.org/view.php?id=5665 is related to this bug.

Fixing of this bug is very important to me - I raise the sponsorship ...

#8

Updated by Tolleiv Nietsch about 12 years ago

I can't reproduce this ... why would oyu even place an image within the section itself? The image should sit inside a container which is part of the section ... could someone check wether this issue is still relevant?

Btw - Flexformhandling is not a TemplaVoila issue - that's a Core issue

#9

Updated by Darren Clark over 11 years ago

Ok this issue doesn't exist with 4.3.2 and templavoila 1.5.0 so for me the issue is closed.

Also available in: Atom PDF