Project

General

Profile

Actions

Feature #17268

closed

Add TSconfig parameters to save/load inline records based on a special inline elements folder

Added by Jo Hasenau about 17 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-05-01
Due date:
% Done:

0%

Estimated time:
PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

The default behaviour for inline records created with the new IRRE features is to reside on the same page as the parent element.
If you are using the CSV version this is true for the elements and if you are using the MM version this is true at least for the records of the MM tables.

For the ICE pack it would be essential to have the possibility of choosing a special folder to save all inline elements.

To make this more comfortable it would be cool if there would be a TSconfig parameter available, that would

a) switch the behaviour on demand
b) provide the uid of the folder that should be used as inline container
c) make this recursively available so that subpages would inherit the value from their rootline.

We discussed that at T3DD07 already and came to the conclusion that the "general recrod storage page" would be no option due to conflicts with other extensions that are already using it. So TSconfig should be the way to go.

(issue imported from #M5538)


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #17463: Configure PID for new elements using IRREClosed2007-07-12

Actions
Is duplicate of TYPO3 Core - Feature #17125: Storage page for child recordsClosedOliver Hader2007-03-16

Actions
Actions #1

Updated by Oliver Hader about 17 years ago

Hi Joey,

what do you mean by "a) switch the behaviour on demand"? I'm working on "Conditions for the TSconfig in back-end" which is currently not possible (see bug #17299).
The points "b)" and "c)" or okay. Subpages always inherit the settings from their parents.

What do you think about a per-table-definition, like e.g.:

TCEFORM.tx_myext_child.pid = 123
TCEFORM.tx_myext_anothertable.pid = 456

or should it be more like
TCEFORM.inlineChildrenStoragePage = 123

Actions #2

Updated by Jo Hasenau about 17 years ago

"switch the behaviour on demand" just means: If there is a setting providing the uid of a storage folder use this, else store the inline elements at the page of the parent element.

I think a per table definition would be the better choice, since you could have different tables using IRRE features and usually you don't want them all to use the same storage folder.

Actions #3

Updated by Oliver Hader about 17 years ago

Okay, so this could work like the following User TSconfig:

TCAdefaults.ty_myext_child.pid = 123

But it should only be applied if used in IRRE context because it might lead to some confusion if you create a tt_news record on a page that isn't visible at the same after saving (because of being moved to the one defined in TSconfig).

Actions #4

Updated by Daniel Poetzinger over 16 years ago

Using User-TSConfig has the disadvatage that you cannot use Page TS-Config.

I guess most use cases would like to have that option on a per-page or per-record level.

Actions #5

Updated by Oliver Hader over 16 years ago

TCAdefaults is in TYPO3 4.2 also available on Page TSconfig.
see http://wiki.typo3.org/index.php/Pending_Documentation#doc_core_tsconfig and search for "TCAdefaults" by Wolfgang Klinger

Actions #6

Updated by Georg Ringer over 16 years ago

TCAdefaults generally doesnt work in IRRE which should be fixed and forcing the pid is also a quite needed feature!

Actions #7

Updated by Oliver Hader over 16 years ago

This was fixed in #0005242.

Actions #8

Updated by Martin Terber over 12 years ago

  • Target version deleted (0)

Has this feature been been pushed to core already? Which version?
And is #5242 the correct related ticket (Redesign browse_links window), or is this a typo?
Thanks.

Actions

Also available in: Atom PDF