Bug #17396

HMENU with special=list does not take workspace into account in FE-Preview

Added by Helmut Hummel almost 14 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2007-06-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Even if the title/nav_title of a page is changed in the workspace, the HMENU outputs the tilte/nav_title of the Live-Page.
It works fine fith special=rootline or without special setting for a normal menu.

My Setup is simple:

temp.nav_main.20 = HMENU
temp.nav_main.20 {
special = list
special.value = 1,153,316,403,286
1 = TMENU
1 {
noBlur = 1
wrap = <ul>|</ul>
NO = 1
NO.allWrap = <li>|</li>
NO.ATagBeforeWrap = 1
}
}

Change the title of a page, and see, that the FE-Preview shows the Live-Page title.
(issue imported from #M5817)


Related issues

Is duplicate of TYPO3 Core - Bug #17338: Sitemap Content Element does not honorate WorkspacesClosedSusanne Moog2007-05-29

Actions
#1

Updated by Sacha Vorbeck about 13 years ago

This is related to 5699

#2

Updated by Michael Stucki over 7 years ago

  • Category changed from Miscellaneous to Workspaces
#3

Updated by Michael Stucki over 7 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (0)
#4

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF